Software Updates Failed Notification

So, I recently upgraded from 16.2 core to 17 core using the upgrade tool but I'm not sure if it completed because the wizard crashed before I got a confirmation. The UI looks different and most things seem to be working as they should but it's been a little buggy and at startup I get a notification from the software center saying: "Software Updates Failed, an important operating system update failed. After I click on it, and dismiss it, everything appears to be up to date. I'm really hoping everything is ok because, like a knucklehead I didn't backup anything before attempting the upgrade so I really want to avoid losing everything with a fresh install.



Try run the updating through the terminal and post in/output.
sudo apt update && sudo apt upgrade

jdmorris81@jdmorris-Precision-7510:~$ sudo apt update && sudo apt upgrade
[sudo] password for jdmorris81:
╭─ Updating Package List ──────────────────────────────────────────────────────╮
│No Change: Index of /patches/ jammy InRelease │
│No Change: https://packages.bluemail.me/repos/debian ./ InRelease │
│No Change: Index of /apps/ jammy InRelease │
│No Change: Index of /drivers/ jammy InRelease │
│Updated: Index of /repos/code/ stable/main amd64 Package…│
│Updated: Index of /repos/code/ stable/main arm64 Package…│
│No Change: Index of /zorinos/apps/ubuntu jammy InRelease │
│No Change: Index of /zorinos/drivers/ubuntu jammy InRelease │
│No Change: Index of /ubuntu jammy-backports InRelease │
│No Change: Index of /zorinos/patches/ubuntu jammy InRelease │
│No Change: Index of /zorinos/stable/ubuntu jammy InRelease │
│Fetched 282 KB in 3s (0 Bytes/s) │
╰──────────────────────────────────────────────────────────────────────────────╯
31 packages can be upgraded. Run 'nala list --upgradable' to see them.
╭─ Updating Package List ──────────────────────────────────────────────────────╮
│No Change: https://dl.google.com/linux/chrome/deb stable InRelease │
│No Change: Index of /patches/ jammy InRelease │
│No Change: Index of /zorinos/apps/ubuntu jammy InRelease │
│No Change: Index of /ubuntu jammy-updates InRelease │
│No Change: Index of /apps/ jammy InRelease │
│No Change: https://packages.bluemail.me/repos/debian ./ InRelease │
│No Change: Index of /ubuntu jammy-backports InRelease │
│No Change: Index of /drivers/ jammy InRelease │
│No Change: Index of /zorinos/drivers/ubuntu jammy InRelease │
│No Change: Index of /zorinos/patches/ubuntu jammy InRelease │
│No Change: Index of /zorinos/stable/ubuntu jammy InRelease │
│Fetched 0 Bytes in 2s (0 Bytes/s) │
╰──────────────────────────────────────────────────────────────────────────────╯

Upgrading

Package: Old Version: New Version: Size:
google-chrome-stable 121.0.6167.184-1 122.0.6261.57-1 106.4 MB
language-pack-en 1:22.04+20230801 1:22.04+2024021 2 KB
2
language-pack-en-base 1:22.04+20230801 1:22.04+2024021 439 KB
2
language-pack-gnome-en 1:22.04+20230801 1:22.04+2024021 2 KB
2
language-pack-gnome-en-… 1:22.04+20230801 1:22.04+2024021 481 KB
2
libegl-mesa0 23.0.4-0ubuntu1~ 23.2.1-1ubuntu3 118 KB
22.04.1 .1~22.04.2
libgbm1 23.0.4-0ubuntu1~ 23.2.1-1ubuntu3 34 KB
22.04.1 .1~22.04.2
libgbm1:i386 23.0.4-0ubuntu1~ 23.2.1-1ubuntu3 35 KB
22.04.1 .1~22.04.2
libgl1-mesa-dev 23.0.4-0ubuntu1~ 23.2.1-1ubuntu3 7 KB
22.04.1 .1~22.04.2
libgl1-mesa-dri 23.0.4-0ubuntu1~ 23.2.1-1ubuntu3 8.9 MB
22.04.1 .1~22.04.2
libgl1-mesa-dri:i386 23.0.4-0ubuntu1~ 23.2.1-1ubuntu3 9.2 MB
22.04.1 .1~22.04.2
libglapi-mesa 23.0.4-0ubuntu1~ 23.2.1-1ubuntu3 37 KB
22.04.1 .1~22.04.2
libglapi-mesa:i386 23.0.4-0ubuntu1~ 23.2.1-1ubuntu3 35 KB
22.04.1 .1~22.04.2
libglx-mesa0 23.0.4-0ubuntu1~ 23.2.1-1ubuntu3 158 KB
22.04.1 .1~22.04.2
libglx-mesa0:i386 23.0.4-0ubuntu1~ 23.2.1-1ubuntu3 169 KB
22.04.1 .1~22.04.2
libosmesa6 23.0.4-0ubuntu1~ 23.2.1-1ubuntu3 3.1 MB
22.04.1 .1~22.04.2
libosmesa6:i386 23.0.4-0ubuntu1~ 23.2.1-1ubuntu3 3.3 MB
22.04.1 .1~22.04.2
libxatracker2 23.0.4-0ubuntu1~ 23.2.1-1ubuntu3 2.1 MB
22.04.1 .1~22.04.2
mesa-va-drivers 23.0.4-0ubuntu1~ 23.2.1-1ubuntu3 4.1 MB
22.04.1 .1~22.04.2
mesa-vdpau-drivers 23.0.4-0ubuntu1~ 23.2.1-1ubuntu3 3.8 MB
22.04.1 .1~22.04.2
mesa-vulkan-drivers 23.0.4-0ubuntu1~ 23.2.1-1ubuntu3 10.7 MB
22.04.1 .1~22.04.2
mesa-vulkan-drivers:i386 23.0.4-0ubuntu1~ 23.2.1-1ubuntu3 11.1 MB
22.04.1 .1~22.04.2
qemu-block-extra 1:6.2+dfsg-2ubun 1:6.2+dfsg-2ubu 68 KB
tu6.16 ntu6.17
qemu-system-common 1:6.2+dfsg-2ubun 1:6.2+dfsg-2ubu 2.0 MB
tu6.16 ntu6.17
qemu-system-data 1:6.2+dfsg-2ubun 1:6.2+dfsg-2ubu 1.4 MB
tu6.16 ntu6.17
qemu-system-gui 1:6.2+dfsg-2ubun 1:6.2+dfsg-2ubu 220 KB
tu6.16 ntu6.17
qemu-system-x86 1:6.2+dfsg-2ubun 1:6.2+dfsg-2ubu 10.1 MB
tu6.16 ntu6.17
qemu-utils 1:6.2+dfsg-2ubun 1:6.2+dfsg-2ubu 1.5 MB
tu6.16 ntu6.17
unzip 6.0-26ubuntu3.1 6.0-26ubuntu3.2 175 KB
zorin-exec-guard-app-db 1.2.14 1.2.15 6 KB
zorin-os-upgrader 1.2.13 1.2.14 464 KB

================================================================================
Summary

Upgrade 31 Packages

Total download size 180.2 MB
Disk space required 22.6 MB

Do you want to continue? [Y/n] y
╭─ Downloading… ───────────────────────────────────────────────────────────────╮
│ Total Packages: 31/31 │
│ Last Completed: google-chrome-stable_122.0.6261.57-1_amd64.deb │
│ Time Remaining: 0:00:00 ━━━━━━━━━━━━━━━━━ 100.0% • 180.2/180.2 MB • 1.1 MB/s │
╰──────────────────────────────────────────────────────────────────────────────╯
╭─ Updating Packages ──────────────────────────────────────────────────────────╮
│Generating locales (this might take a while) │
│Generation complete. │
│Setting up: language-pack-gnome-en-base (1:22.04+20240212) │
│Processing: triggers for mailcap (3.70+nmu1ubuntu1) │
│Processing: triggers for desktop-file-utils (0.26-1ubuntu3) │
│Processing: triggers for hicolor-icon-theme (0.17-2) │
│Processing: triggers for gnome-menus (3.36.0-1ubuntu3) │
│Processing: triggers for libglib2.0-0:amd64 (2.72.4-0ubuntu2.2) │
│Processing: triggers for libglib2.0-0:i386 (2.72.4-0ubuntu2.2) │
│Processing: triggers for libc-bin (2.35-0ubuntu3.6) │
│Processing: triggers for man-db (2.10.2-1) │
│Processing: triggers for dbus (1.12.20-2ubuntu4.1) │
│╭────────────────────────────────────────────────────────────────────────────╮│
││✔ Running dpkg … ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 100.0% • 0:00:00 • 63/63││
│╰────────────────────────────────────────────────────────────────────────────╯│
╰──────────────────────────────────────────────────────────────────────────────╯
Finished Successfully
jdmorris81@jdmorris-Precision-7510:~$

It looks normal enough. Try see if the command fixed your problem.

I followed with a reboot, same popup from the software center upon startup.

Try this:

1 Like

I think this will solve it for you:

By the way, I did struggle a lot with it and eventually solved it by doing a new clean install. Another solution I did was to disable fwupd by creating mask symlinks. However I have removed those symlinks now, as it worked with a clean install. But only in frontend, as it still give errors related to fwupd when I do "sudo systemctl status fwupd" in terminal. However I am fine with that.

If you don't want to do a clean install, I think the best solution is the one posted by @a67016188 in the first link above in my reply.

So, I would run the command with the number in the error listed above in my screenshot like this?:
sudo grep -rnw /var/ -e 'a45df35ac0e948ee180fe216a5f703f32dda163f'

Ok, I ran sudo grep -rnw /var/ -e 'a45df35ac0e948ee180fe216a5f703f32dda163f'
Is it one of these last 3 files?

Resolved! :tada: Thank you sir

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.