Software updates says I need more space

Interesting I started up this morning and updates said I have downloads ....

I clicked install and this message popped up ...... I did as requested in the terminal but didn't change anything as far as installing the additional downloads

Here is my GParted screen shot .....

Do I have to make more room on my /boot partition ???? I thought that was the recommended size for /boot .... I dual boot with dual drives .... Win 10 on one drive and Zorin on the other .... using Cinnamon DE

Have you run

sudo apt clean && sudo apt autoremove

?

1 Like

No I used the one they suggested ...... sudo apt autoremove .... let me try the one you posted ....

Got this looks like it didn't remove anything .....

mike@mike-ROG-Strix-G731GT-G731GT:~$ sudo apt clean && sudo apt autoremove
[sudo] password for mike:
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 29 not upgraded.
mike@mike-ROG-Strix-G731GT-G731GT:~$

What is the output of

dpkg --list | grep linux-image

You may need to remove older listed kernels.

1 Like

mike@mike-ROG-Strix-G731GT-G731GT:~$ dpkg --list | grep linux-image
rc linux-image-5.11.0-27-generic 5.11.0-27.29~20.04.1 amd64 Signed kernel image generic
rc linux-image-5.11.0-41-generic 5.11.0-41.45~20.04.1 amd64 Signed kernel image generic
rc linux-image-5.13.0-27-generic 5.13.0-27.29~20.04.1 amd64 Signed kernel image generic
ii linux-image-5.13.0-28-generic 5.13.0-28.31~20.04.1 amd64 Signed kernel image generic
ii linux-image-5.13.0-30-generic 5.13.0-30.33~20.04.1 amd64 Signed kernel image generic
ii linux-image-generic-hwe-20.04 5.13.0.30.33~20.04.17 amd64 Generic Linux kernel image
mike@mike-ROG-Strix-G731GT-G731GT:~$

All of these can go.
I might do a fast command to remove them all but...
Let's do something different in order to promote maintenance.

sudo add-apt-repository ppa:gerardpuig/ppa

sudo apt update && sudo apt install ubuntu-cleaner

Run Ubuntu Cleaner by checking all of the boxes in the left pane, then checking all of the boxes in the right pane.
All the boxes.
You will need to enter your sudo password.
You may need to run it more than once - as it must clear some things before others. Run it until it says yous system is all clean.
Close it out, then run your updater or run

sudo apt upgrade

This should get you all fixed for now...
But it also gives you a Maintenance tool- run Ubuntu Cleaner about once per week.

3 Likes

Thank you sir everything worked just great with no error messages .... as you said I will set up a schedule and run Ubuntu Cleaner once a week .... :+1: :beer:

1 Like

I had to install a saved back-up from Rescuezilla yesterday and it was about 1 week old so I had to run the Ubuntu Cleaner again ... this time I got a warning message (see below) but everything else was OK ....

Preparing to unpack .../076-libfwupdplugin5_1.7.5-3~20.04.1_a
md64.deb ...
Unpacking libfwupdplugin5:amd64 (1.7.5-3~20.04.1) ...
Preparing to unpack .../077-fwupd_1.7.5-3~20.04.1_amd64.deb .
..
Unpacking fwupd (1.7.5-3~20.04.1) over (1.5.11-0ubuntu1~20.04
.2) ...
dpkg: warning: unable to delete old directory '/var/lib/fwupd
': Directory not empty
Preparing to unpack .../078-gtk-update-icon-cache_3.24.20-0ub
untu1.1_amd64.deb ...
Unpacking gtk-update-icon-cache (3.24.20-0ubuntu1.1) over (3.
24.20-0ubuntu1) ...
Selecting previously unselected package libcdr-0.1-1:amd64.
Preparing to unpack .../079-libcdr-0.1-1_0.1.6-1build2_amd64.
deb ...

Is this anything to worry about or correct .... going to do another Rescuezilla later today after I get some more stuff reinstalled ...

This is nothing to worry about. It is a safety and security thing to not delete or remove non-empty directories, as something important may be deleted if done - And the system is impressive but still not intelligent.

1 Like

Thank you sir .... then I shall proceed with the back-up ....