Solaar broke media buttons and tuned them into F keys

I have a Logi keyboard that had a minor issue.
I installed Solaar, but that gave me almost no options and it didn't fix the issue.
Since installing Solaar the media buttons don't work anymore (they behave like F keys), removing and purging doesn't work to get the media buttons back.

Is there a way to:

  • undo what Solaar did to my settings?
  • or resetting all the keyboard settings?
  • or telling Linux I want the media buttons instead of the F keys?

You might try:

gsettings reset-recursively org.gnome.settings-daemon.plugins.media-keys

1 Like

Thanks, but that didn't work.

I have never used Solaar and I'd rather not download it in order to inspect it.

Have you searched your config folders for any Solaar leftovers?
Have you tried renaming your ~/.config directory to .config-bkp and logging out and back in again?

Searching the web... I came across these tips:

The important part is xmodmap -pke
Perhaps other users that have used Solaar app may be able to offer some pointers, too.

1 Like

That does work!
And it turned out there was still a solaar/ folder in there.
After deleting solaar/ and reverting the rest, my keyboard is still broken, so now I'm figure ring out what other folder or file inside .config/ is responsible.

I thought doing a apt purge command removed everything, but that does not seem to be the case?

Apt --purge command will remove the configuration files From The Installation files, clearing it out of apt. But it doe snot remove the configuration files that get installed. The wording on this is confusing... And I do not know if my wording above helps it any...

1 Like

After messing around with .confog/ I accidentally deleted everything. :innocent:
So I reinstalled Zorin OS completely.

The media buttons on my laptops keyboard work again, but on my external keyboard they still don't.
I don't know what Solaar did to my keyboard, but I'm never ever installing that app again!

It seems a common keyboard problem.
I'll post the solution here if I find one!

2 Likes

I was able to fix it by pressing fn+esc, then the default fn state switches.

1 Like

Are you ready to mark that as the "Solution" or still testing?
Please use the :ballot_box_with_check: Solution flag on the effective post, to indicate the solution to others.

3 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.