[solved] No graphical desktop login - screen is black with blinking cursor - TTY login works, though

Hi,
I thought I’d reactivate my elder IBM Thinkpad T43p for my grandson, so I installed Zorin Education Lite 32bit last night. Everything seemed to work ok. Using the graphical desktop, I added another user, switched to it, rebooted the machine, etc. All without problem. Finally I put the machine in suspend state.

This morning when I started from suspend mode, the destop lock screen appeared as expected. I clicked on “logout” (actually “Abmelden” since it is running with German language). The screen went black with only a small underscore blinking at the top left. Some disk activity was going on but after a lonng time waiting, I thought the graphical login should have long appeared.

I forced a power off, then restarted the machine, but no joy. As the machine starts up, I see, first, a narrow frame arround the screen, then the screen goes to black, and some time later the ZORIN logo comes floating in as expected. Finally the screen goes to black again and instead of the desktop to appear, the screen goes to all black (in text mode, I think) with that small undersocre character blinking at the top left. Nothing more happens.

I can well login to a TTY (alt-ctrl-F1), and work from there, so the machine is not dead. I do have a little expetience with Linux but don’t have a clue how to fix that window manager problem, what it seems to be.

I found this link i the forum


and followed all the update steps suggested there, but the problem persists.

Any hint what I need to do or try?
Cheers, Peter

If you login on the console and run

xwmconfig

or

startx

Does it bring up the xfce desktop or an error?

startx

does bring up the desktop.

xwmconfig

is not found.

Could you please also monitor Black screen after update ?
That thread is still work-in-progress but it may have some suggestions for you.

I already read that thread before starting this thread. I don’t think this is the same problem. I also tried the nomodeset quiet splash suggested there, but it didn’t help-

In the meantime, I was working with the graphical session that came up after startx and had not seen any problem. Even going to suspend mode and waking up again did not cause any problem.

So, basically, X11 and the desktop are working fine. It is only the auto-start of the desktop at boot time which doesn’t work anymore.

Any clue how to debug this? What logfiles could give a hint?

From other sites, XFCE doesn’t automatically contain a display manager to support login, lock screen etc. and they suggest installing lightdm.

sudo apt install -y lightdm lightdm-gtk-greeter

sudo systemctl enable lightdm

I haven’t tried this or know if it works, so use this at your own risk.

Well, I did a fresh install of Zorin Educ Lite 32 and this did automatically start a graphical desktop with graphical login, and this all worked nicely.

Even after the suspend state over night, it woke-up and presented the graphical login. It was when I clicked the log-out button when it turned to the black screen.

Something in the “auto-startx” enviroment got damaged somehow. And I don’t have a clue where to start debugging this.

Sorry but could you confirm that after the reinstall, the system is working fine or is the logout problem still there? Also, could you let us know if the system is still working fine after you have run all updates? Thanks.

Some misunderstanding here, probably. Beg your pardon.

I did a clean install yesterday, and everything worked smoothly until this morning. I dod not do another install. This is an old Thinpad T43p, it does’t support boot from USB, so I had to install using the DVD-drive. It took eons to install, and I’m trying to avoid reinstalling.

The system is up to date; I just checked again.

I’d be happy to RTFM but I don’t have a clue where to start. Again, the graphical desktop does work when I login to, say, TTY1 and then issue STARTX. It simply is not coming up automatically (the one I can reach with ctrl-alt-F7 normally). The screen is black except for the cursor blinking at the top left.

phunsoft,

This problem sounds very similar to the one that carmar referred to above. I realize that you have already checked this thread, but did you try the link to what seems to be a solution?

We’ve been able to find the source of this error – which appears to only affect Zorin OS 15 Lite 32-bit – and publish a fix for it in the latest software updates.

You can find more details about it and how to apply the fix to any computer experiencing the issue in my post on the thread here:

2 Likes

My bad, I was looking at


not the one referred to by carmar. Overlooked that when I replied. Sorry.

I have now started to work through the right thread. And it seems the problem has been identified and fixed (many thanks to AZorin).

Will report here when I succeeded.

I followed the instructions given by AZorin in that other thread and the problem is gone! Great.

Just a side note: On my Thinkpad, I need to hold down the ESC key instead of the left SHIFT key to show the Grub menu.

A post was split to a new topic: Zorin OS 16 black screen with blinking cursor