[SOLVED] Screen Resolution Issues

I'm having this issue that when I load up the system Zorin Core, I'm getting set to 640x640 resolution I've tried to fix it but I get the error message "Can't find gamma of the display" and well so far I've tried to force it with grub but didn't work neither did using xrandr work.

Can you please run

sudo nano /etc/default/grub

On this line
add the nomodeset parameter so that it looks exactly like
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
Tap ctrl+x to exit, then the y key to say yes to save, then the enter key.

sudo update-grub

Reboot and test...

Didn't work sorry for the late response I went to college.

Are you using Nvidia, Intel or AMD Graphics card?


In terminal, let's undo what we tried that did not work:

sudo nano /etc/default/grub

Change GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
back to
Tap ctrl+x to exit, then the y key to say yes to save, then the enter key.

sudo update-grub

Now run the following to update Nvidia Drivers:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

sudo apt update && sudo apt full-upgrade

The first command "sudo add-apt-repository ppa:ubuntu-x-swat/updates" didn't work.

It is this repository:

It is up to date and maintained. Are you connected to internet?
Was there a Typo in your CLI command?

Whoopsies I wrote app instead of add sorry about that that's on me.

1 Like

OK so that's worked should I restart again?

1 Like

Yep, let's see if it did any good...


It sadly didn't work.

The only new thing is my hotbar has... Vanished

In terminal, can you run

sudo apt update && sudo ubuntu-drivers install

Open Software & Updates and move to the "Addityional drivers" tab.
Can you relay what shows up there?


In that list of options, what happens if you click on the 470 (Proprietary tested) driver?

Well let's find out and see

Welp I can tell you for sure that it's not a list to enable and disable so thats off the list.

It should do so... it does on mine.
What Specific Nvidia card are you using?