Some downloads standing still


I'm on Zorin 16.3 and have an issue with some downloads from the software store seemlingly just standing still at 0%. I am on a slow connection but I am able to install some apps.

Example: Xonotic game downloads just fine, starts ticking up as soon as I click install. Other software such as Bottles or Freedesk Platform (which reports having an update available) just stands still at 0%.

Any help is appreciated! :slight_smile:

I occasionally also get this:

If Software Updater is set pointing to a regional server, set it to "Main Server".

It already seems to be set to main server.
Screenshot from 2023-08-17 17-58-36

1 Like

Is this happening on different occassions at different times of day?
If it is a one-off, just wait and try later. It may just be a server side or internet issue.

You could try one of the solutions in this link:


I think it's always like this.

Thanks, I'll check it out.

How "slow" is your connection? The game is 1,2 GB big, that might take very long with the possibility of download problems.
Be aware you can also run Xonotic without installing: Download Xonotic 0.8.6 - Xonotic

Did your try to download the flatpak or the snap version?

Bottles seems to be Flatpak, too. What about Freedesk Platform?

1 Like

Just as this message says, you have duplicate sources.
In terminal, you can run

sudo apt update

and double check for other errors.
If you elevate to root

sudo -i

Launch file manager


Navigate to "Other locations" in the left pane. Then "computer" in the right pane. Now, click etc to open it. Then apt. Right click on sources.list and select to open with Text Editor.
In the text editor, display Line Numbers.

Scroll down to line #57 and check if it is for Wine.

1 Like

One of the solutions to 1 and 2 seemed to do the trick! :slight_smile:

That's the thing, Xonotic started downloading instantly and was done in about 15-20 minutes where as some other, smaller downloads were never get past 0%.

Speed differs during the day due to a 4G connection, right now I'm getting 10 Mbps down and 15 up.

1 Like

Line #57 seems to be for Wine. deb focal main

Here is the full file:

# deb cdrom:[Zorin-OS 16.3 Core 64bit]/ focal main restricted

# See for how to upgrade to
# newer versions of the distribution.
deb focal main restricted
# deb-src focal main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb focal-updates main restricted
# deb-src focal-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
# deb-src focal universe
deb focal-updates universe
# deb-src focal-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb focal multiverse
# deb-src focal multiverse
deb focal-updates multiverse
# deb-src focal-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb focal-backports main restricted universe multiverse
# deb-src focal-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb focal partner
# deb-src focal partner

deb focal-security main restricted
# deb-src focal-security main restricted
deb focal-security universe
# deb-src focal-security universe
deb focal-security multiverse
# deb-src focal-security multiverse

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
deb focal main
# deb-src focal main

You can remove

deb focal main
# deb-src focal main

and keep the source you have saved in /etc/apt/sources.list.d as the only Wine Source.
Be sure to save the sources.list after making changes.

In /etc/apt/sources.list.d I have a file called winehq-focal.sources with the following:

Types: deb
Suites: focal
Components: main
Architectures: amd64 i386
Signed-By: /etc/apt/keyrings/winehq-archive.key

That URI is the same as in the sources.list file. Do I understand correct that I shouldn't replace anything in sources.list, just remove those lines?

How did you download it? Directly?
If otherwise: snap or flatpak?

1 Like

Correct. Those lines are a Duplicate. Possibly from making more than one attempt to install Wine by adding the repository. Just remove the duplicate lines exactly as I quoted them above.
Once they are removed and the file saved, running sudo apt update in terminal will refresh all your sources.
So you would need to re-launch Gnome Software Store after doing the above.

Flatpack from the software store.

I also have a file with those same two lines. Is this something I need to do anything about?

No, those can safely be left as they are.

I presume that running

flatpak refresh

in terminal helped with this issue? I notice you have marked this thread as solved.

Yes @Turtle11 sent a thread with a solution that worked and enabled me to download bottles. I did not run flatpack refresh, but instead tried the first three commands from that thread.

You seem to have solved the other issue with Unable to get list of updates.

1 Like