Stuck in bash mode TTYL

Trying to update Python, traffic crash took out community power supply.
Now stuck in bash screen - TTYL-(system product name, system product pword)
Can access grub and usual "repair" options but still reboots back to bash. Seems I have lost desktop.
Tried the usual tricks in my deck, apt etc restore, update, upgrade, ends with broken packages.
Tried resintall Zorin-desktop but cant be found.
Sort of stuck now - just need a hoodie and a dark room~
Also tried: sudo apt --fix-broken install && sudo apt full-upgrade (replied nothing to do.)
Tried various combos of fix-missing, command not recognised.
Any help greatly appreciated - cheers.
P/s Reading an unrelated post, I realisedd it isn't Zorin is it. It's zorin os, so tried reinstall zoring os desktop.
About 45 minutes and several thousand lines later - reboot, Bingo,we're back!

Warning: although this worked in my case, be aware it will revive the dead, ie, reinstall all apps etc, including those you have previously deleted. It may also delete some extensions and throw up a system error message.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.