Stuck on boot screen ZorinOS 16


Yesterday I've installed ZorinOS 16, completely removing my previous OS, Windows 10.
I chose Nvidia type of installation since I have Nvidia GeForce 940M and I've encountered some issues that I mentioned here:

But that's not the main issue right now. Today I installed GNOME Tweaks and I've tried rebooting but I never made it since I'm stuck on boot screen (ACER). I tried adding nomodeset to GRUB but it still doesn't work since it gives me DMAR error saying that no firmware reserved region can cover this and that HDMI/DP requires binding with gfx driver.

Additional info: I have formatted my SSD to ext4 in the process of installation, and I have used ntfsfix on my secondary HDD NTFS drive that I didn't format in order to enable modifying on that drive.
Also, please check that Reddit post where I mentioned tinkering BIOS in order to make it work.

What have I done wrong, why can't I boot all of a sudden?

This is an old thread but might be worth a try. Disabling secure boot in the BIOS:

In addition, try reinstalling with Linux own drivers (Nouveau) and not the nVidia ones, then look at installing the nvidia drivers (unless you are happy with the performance of the Nouveau driver which is present in the Linux kernel by default) after you have your system up and running (hopefully).


His nvidia card is not legacy and can use the latest version 470.94.

I have a acer predator laptop that didnt come with a dual gpu chip (intel and nvidia). If you can check in the bios to turn off the hybrid mode that would be great.

For dmar i found this

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.