Stylus & Late 2015 iMac Graphic Drivers

Hi Friends!

I’ve installed Zorin 16 Ultimate on my Late 2015 iMac and I’m running into a couple of hangups:

  1. My trackpad works well with touch, however it does not recognize a stylus, as Ubuntu 21 did.

  2. My machine is taking about 5 of more minutes to boot up or shutdown, and I understand it may be the result of a Graphic Drivers issue.

Do any of you have a solve for either of these?

Thank you so much in advance! :slight_smile:

ZorinOS 16.x is based on an older version of Ubuntu, notably, 20.04 LTS

While this is true as a base, Zorin OS uses the same kernel as 21.04... So, this may still be an open case.

This could be graphics drivers, or it could be due to a corrupted file (that happened during install). If this is a fresh installation and performing a Reinstallation of Zorin OS is a viable option - this is what I would recommend. It would be much easier than trying to track down the corrupted file - and it would deal with any unknown corruption that has less obvious symptoms.

Otherwise, try running

journalctl -b

or checking the contents of /var/log/boot.log to see if there are any clues for the delayed boot times.

Thank you, TGRush!

I wasn’t aware of that that.

Thank you, Aravisian!

I have tried reinstalling it, and other distro without success. Each takes about 5 or more minutes to boot up, shutdown, and restart.

I’ve just tried journalctl -b, which brought up some productive looking code, although it hasn’t seemed to work just yet either.

This makes it sound like a setting in your Motherboard EFI settings needs to be configured...

can you upload that to some paste site?
like uploadgram-paste or something?
maybe we can look into it and find what is making the boot times be so slow, possibly, it's Systemd waiting for something else to finish, until it decides to just stop waiting at the 5 minute mark :thinking: