Sudden refusal to boot zorin 15.3 ultimate

As a Windows (business and personal) user since it Microsoft launched it way back I have tried Linux distros several times but never felt that it was for me so I decided to try Zorin 15.3 Ultimate as this seemed to do the job. All went well and I was getting very impressed with how it all loaded drivers and printers and even MS Software but to day that all went wrong. I was entering authorisation details ( one of my beefs----to often) then PC went to black screen and nothing else . Tried to re boot which led me to the recovery menus. Offered to boot in to Zorin but this just started doing it for about 1 minute then a very very quick screen with a message then nothing. I have tried ALL the recovery options and all the many Google suggestions but nothing worked. The quick message read
Zorin OS 15 Created slice user slice of Peter. Starting use manager for UID 1000''' then started session 1 of user peter. This is meaningless to me !!. I could do a new installation as I have no data to loose but as I am an Engineer I like to be able to FIX things. I can fix Windows any time as I have many years experience so any clues what to try next.
Thanks in advance

This is a log entry that shows that your User account logged in. It is not an error message; I suspect it is just the only thing you are seeing.

Can you clarify this statement? Entering your root password would not crash the system- What were you doing that required your root password to perform?

Please bear with me here. I THINK I must have unmounted the dev/sda1 drive as I was trying to get COMPUTER on the the desktop. Sorry that is the best I can do

In Zorin (Or Linux in general), "COMPUTER" is the Root directory. On most all File managers, you can access this quickly with the Up arrow Icon on the toolbar of the window manager. Except Nautilus (default Gnome File manager). Because it just has to be different...
In Nautilus, the left Sidepane contains an entry that says, "Other Locations". Select that, then select computer. It makes no sense.

Have you tried booting into the Recovery Menu, then mounting your drive?

sudo mount /dev/sda1

You can check your drives with lsblk -f and also get your UUID on them.

If that fails, you may need to edit your fstab file using the LiveUSB copy of Zorin to access /dev/sda1, then edit the fstab file.
The fstab file should look something like:

sudo nano /etc/fstab
UUID=0935df16-40b0-48 /home/user/mountpoint ext4 defaults 0 0

Hello Thanks for the info .Could not mount that drive from Zorin at all. Opened up my old PuppyLinux PC and went through ALL methods of mounting without success. Examining the primary partition told me it was corrupted so could not view any of the files on disk. Then used my Windows PC with professional partition management tool and could then see all the files but /etc/fstb does not exist. So I think I have wasted enough time on this one so will re install and spend some more time setting it up again,
Thanks again

1 Like

Yet another story, Puppy to the rescue :dog2:
While I do not use Puppy for my daily computing, it can be a great life saver in case like this :slight_smile:

Out of pure interest I found an old Linux Ubuntu repair CD and ran it an this is the output. It means nothing to me but it could not fix any errors.
Error mounting /dev/sda1 at /media/lubuntu/a316ce1b-72aa-4a1d-9946-b2767b074b82: Command-line `mount -t "ext4" -o "uhelper=udisks2,nodev,nosuid" "/dev/sda1" "/media/lubuntu/a316ce1b-72aa-4a1d-9946-b2767b074b82"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sda1,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

If booting from LiveUSB (or Live CD), then it is more involved than just using the mount command than it is from recovery menu where you are actively booting the same system.

Looks like fsck would have helped you more than mounting the drive would.

In fairness... All I had to go on was that you said you think you unmounted your primary drive.
When I migrated from Windows to Linux, in learning the system, I did a lot of things that I was not sure what I did after. And had similar results.
I was constantly getting into root and doing things most users know better than to do.
Had a lot of wipe and reloads of the OS. :smiley:
But with results; it has been a long time since I have found myself in that situation. You are right to test, explore, poke and prod - it works. Even when the computer doesn't always work afterward.

1 Like

It is called "learning from your mistakes". Like a science experiment, if you are unsure what you are doing or how things may turn out, it is good to make notes as you go along. That way you can avoid repeating mistakes.

Exactly. I still experiment, test, poke and prod just as much. I just create disaster far less often.

1 Like

Whilst I have all you learned folks about I had one major issue with Zorin and that was the size of the desktop icons---they are much too big to me. I reduced them to the min size allowed in the software but still far too big. I did some research and found many people with the same issue BUT I could not find a "quick" solution. Is there a way too do it without loads of keyboard input ?

I suffer this problem on my Zorin laptop, not everone has 4k res screens. Small size icons out of the box would be good. I have only a few desktop icons and have reduced the size of them individually to smallest by dragging their corners. They still look oversize compared to Windows icons on same machine, but I have got used to them.

You can install this gnome shell extension:

Then edit: /usr/share/gnome-shell/extensions/desktop-icons@csoriano/prefs.js to change the Icon sizes offered.

For Zorin Lite (XFCE) it is pretty easy:
Settings > Desktop > Icons tab - Select any size from 16px to 256px.

I quite often log in as a root.
My dark past :new_moon:

I thought I would update my ongoing experiences with Zori 15.3. Firstly to some issues encountered along the uphill struggle !
I re installed the program now when I boot up all is well until the Zorin flash screen shows then after that I get mases of code along the LHS of the screen then it gets to the login screen and the code disappears then once I login the code comes back again eventually getting to the correct desktop--any comments ?
Next issue is with DISKS . Clicking on this icon brings up the drives on the PC. I reports my HDD for size and partition info BUT it then goes on to tell me that I have 3803256 bad sectors which I do not have (brand new disc checked by me).
Still the biggest issue is the large size of the desktop Icons. Following the advice in the earlier post by aravision I finally managed to get World Shell extensions installed. I downloaded the tar.gz file and extracted it but then what to do with it.
I read the readme file and tried every way to get it installed but after much googling I gave up as every attempt I made resulted In errors etc. I eventually found a .deb file and this worked correctly and installed the software but it is total rubbish and trashes my desktop see screen shots

This shot is a demo of a normal desktop

This shows what happens when I use the extension (icon size deliberately set large). You will see that it does not affect the usual Nautilus Icons but it adds loads of duplicate + others icons that cannot be moved or altered. Not much use really.
So to sum up there is to much "mucking about" In Zorin for me to use it for business but I may well keep trying and get to know it but it is nowhere near as user friendly as Windows IMHO

1 Like

I do not use Gnome Desktop - so, I must admit I was not aware that extension was that bad.

I might make a different suggestion instead:

Switch to Zorin Lite.
Far more control over what you wish to configure without extensions or adding new things.

1 Like