Synaptic and lightdm greeter issues

I've searched and found a lot of info on my subject but could find nothing pertaining to it.

I've purchased and installed, solely, Zorin OS16.1 pro, on my Dell 5379 laptop. I've been messing around with the free versions long enough to accept the fact that this Zorin is a permanent replacement for Windows, on my system.

I've installed lightdm, conky, xfce and a bunch of other stuff with no overwhelming problems that couldn't be fixed with a trip to our forums. Cool, yes! Lovin it! Here are the two issues I need more advanced help with.

  1. I've installed synaptic and I cannot get it to launch from the icon, I click on it but nothing happens, however, when I enter it from the command line preceded with sudo, it opens fine and I can use it. So i'm guessing there is some kind of permissions issue? I don't know. I've tried reinstalling it a few times with no luck.
  2. lightdm greeter settings. When I click that item in the menu, it starts up but shows me that I do not have proper permissions to apply any changes I might make. I have also tried reinstalling this with no luck.

What are my next moves to fix these issues?
Thanks again and I DO appreciate all of you linux gurus. Maybe someday I can help others with what I am learning from you all.

1 Like

Where is the icon placed? In the app menu or on the panel?
Synaptic always must run with Root Permissions.
This means that you should get a Password Prompt when you launch it... if you do not get the prompt, Synaptic will not launch. So likely - your Password Prompt is what is missing.
Can you try:

sudo apt install --reinstall policykit-1-gnome

(Yes, xfce uses the gnome package)

This is likely the same as above- missing the PW prompt.

1 Like

I'm curious, how did you install synaptic? The most reliable way to install applications is by apt (can be found in the application store, but is intermingled with snap and flatpak. This is confusing, so it would be beneficial to get accustomed to the terminal for installations and upgrades).

After uninstall synaptic from the store, in terminal, type:

sudo apt install synaptic

Aravisian sounds closer to resolving the issue then I... attempt his fixes prior to considering mine.

1 Like

You soooo nailed it!!!
Thank you! Thank you! Thank you all!!