Taskbar became empty. No Z menu 'button'

I ran into today for the first time my screen not showing the Z menu button, nor any of my designated favorites. There was one button (I don't know the right name) with two layers of rectangles. It shows open apps which I could choose among. I couldn't get back to the normal taskbar and the general Z menu button. I was able to Restart, and after that all looks okay.

This somewhat resembles in MS Windows when Explorer crashes. If you know enough to Ctrl-Shft-Esc to get Task Manager up, you can manually invoke Explorer again. If that is the type of thing I ran into in the Linux environment, what would be the equivalent way to re-start the overall desktop environment with the taskbar re-populated? Sorry to bother folks if this is common knowledge among Linux users.

If what I've run into is a bug, does it seem a Zorin package bug, or a component that Zorin folks didn't write but just included? Should I be reporting elsewhere?

It sounds like gnome-shell crashed.
When that happens, you can try hitting alt+f2 to bring up a launcher dialogue, then enter in the letter r (for restart) and hitting enter key to restart the gnome-shell.
If it happens more than once, please update this thread with that info and if you can recall what processes you were doing that may relate to why the shell crashed.

1 Like

@rberke Please remind us which version and flavour of ZorinOS you have installed.

EDIT: @Aravisian just beat me to silver medal position in this race. He is assuming you have Core (i.e. Gnome)

Until you realize it is actually a chocolate wrapped in tin foil...

You're right. Due to Zorin OS 16 currently being in Core only, I am neglecting 15.3 Lite. I need to stop doing that...
That being said; the description the O.P. gave describes Gnome Behavior...

1 Like

I'm running Zorin OS 16 Pro.

Thanks for the Alt-F2, r tip. Gnome handles the general environment similar to in Windows Explorer handles it. If I run into recurrence I'll jot down what was going on right before then.

I think today I had been in a Zoom conference, with Zoom maximized. At the end of the conference I clicked Leave. I think it was right after that I noticed the effects of Gnome crashed.

What graphics card are you using? Dedicated Intel? Nvidia? AMD?

Advanced Micro Devices, Inc. [AMD/ATI] Robson LE [Radeon HD 6330M]

It's a dedicated card, but low end by modern standards.

Please update this thread when it happens again- it may have just been a one time thing.
But since you mentioned Zoom and I have encountered others saying Zoom crashed the shell, it is curious.

I use Zoom and have never experience it. I just remembered my Web cam wasn't working well imma make a forum about it.