Terminal doesn't open after installing Python 3.9

The outcome of the installation with python?

And if you managed to make Python 3.9 works in Zorin, you can provide us a tutorial. It will help future visitors who are seeking the solution for this problem.

It is a stand alone programme.
You create bootable USB, like any other Linux distro.
Boot from this USB and follow GUI.

You need another USB key or USB connected disk to store the image. But Clonezilla/Rescuezilla compresses the image quite well - you really do not need much capacity for a backup drive.

In your xterm, please run:

sudo update-alternatives --config python3


Ah finally. Thanks Aravisian!
I was hoping you could pitch in here.

It only shows python3.9

1 Like

sudo ln -sf /usr/bin/python3.9 /usr/bin/python3

The geniuses at Gnome symlinked the python version to gnome-terminal

I'm wobbbly... just woke up...

Ah, that what it was.
I really could not understand why Python broke the gnome-terminal. Now the whole thing started to make sense.

Now python is again configured with python3.9 which didn't work with the system apps.

It would break a lot of things. I remember when Trekker did this - and not long after, I did the same exact thing.

Is it possible to use the system apps with python3.9? If now I will reinstall linux.

Yes, you can.
In your xterm, can you now

cd /usr/bin


sudo nano gnome-terminal

Right at the top, you will see


change to


save and exit... Then Log out and back in and please try ctrl+alt+t

It doesn't work.

My jaw physically dropped... That worked when it happened to me, even. And my mistakes are notoriously hard to fix.

When you did sudo update-alternatives --config python3 did you make any selection (Even if there was only one selection to make?

Yes. I made one. It did display two selections and both were python 3.9.6. Now if I run the command it gives an error which says the the linkgroup python3 is broken.



Okay. I'll try.

It still doesn't work.
I think the best thing would be to reinstall linux.

Ok, one more thing to try:

sudo apt reinstall python3 python3-minimal python3.8 python3.8-minimal

once done:

It works again! And the main menu too! Everything seems to work now! Thank you!