Terminal Emulators in Zorin Lite

As a new user to Linux, I’m learning how to use the Terminal. The first time I tried to open Terminal from the Apps Menu, it asked me to choose a preferred application, and so I had to randomly pick one. Now that I’ve spent more time looking around, it appears that Zorin comes with 4 different terminal emulators installed (or at least listed separately in the Software Manager).

  1. Terminal Emulator
  2. UXTerm
  3. XTerm
  4. Debian X Terminal Emulator (which isn’t listed in Software Manager, but is shown as an option for Preferred Applications)

No matter which one I launch, the terminal window looks exactly the same. So what’s the difference between these applications. If I’m only using any one, can I remove the other 3?

The default terminal emulator in Zorin Lite is XFCE4-Terminal.
XFCE4-Terminal is dependent on Xterm and Debian X terminal, as it builds from elements in those packages to operate. If, for example, you tried to Uninstall either of those, it would take a lot of your desktop with it. So, no, you cannot remove them; but they are not clogging up a lot of extra space or anything.
Personally, I prefer the XFCE4-Terminal for basic Terminal use and I install it on any desktop I am using that does not come with it. Then I jazz it up with zsh (Z Shell) with word correction and other addons.
You can set your Default Terminal if you have not done so already, by searching “Default apps” in your app menu.

Thanks for the reply. I cannot find specifically where the program name is listed, but I’ll take your word for it that I am using XFCE4-Terminal.

My (subjective) complaints regarding XFCE4-Terminal are:

  • I cannot easily copy to and from the terminal window. (Keep in mind, I’m an ex-Windows user, so I’m used to Ctrl-C and Ctrl-V, but in the terminal window, these shortcuts just make strange symbols.)
  • I wish the entry prompt was more visible (with a different color, and also with an empty line above it. When I try to follow online instructions by using terminal, and if there are multiple pages of lines that appear, it is difficult for me to see where my last entered command is located by scrolling upward.
  • Terminal window does not remember window size from previous use, and always starts in a pretty small window (but can be manually enlarged).

For now, I will continue to use this Terminal until I find a better option.

You can change all of the above in the Terminal Settings, except copy and paste which in Unix and Unix-like systems is ctrl+shift+c and ctrl+shift+v (in the terminal only. This is because in Unix like systems, ctrl+c is already assigned elsewhere).
You can right-click anywhere in the terminal window and select “preferences” from the popover menu.
Or from the Menubar under Edit.
It is also included in the App Menu as xfce4-terminal-preferences.

When I right-click in the terminal window, it just ‘selects’ some rows in the window and turns them white (no popover menu appears).

I don’t seem to have any kind of menu in my Terminal. (There is an arrow in the top-left corner with a drop-down menu which allows me to maximize, minimize, etc.)

And I’m unable to find anything with “xfce4” listed in the App Menu.

(Maybe I have a different version of terminal because I’m on Lite?)

Zorin Lite uses xfce4-terminal

Can you go to Zorin > Settings > Details and click “About” and replay your Zorin Version?
Also, a screen shot of your open terminal may help, too.

Under my Settings, I don’t have a section called ‘Details’ (see the screenshots below).

Terminal

I’m order to be able to change your settings you could start another terminal.

Xfce4-terminal --show-menubar --show-toolbar.

This will allow you to go through the settings, add what you want and customize as you feel. Let us know if this helped

I see in your settings that you have Window Manager and Window Manager tweaks, which is only on XFCE Desktop, not Gnome Desktop.
hit alt+F2 and a small pop up window will appear midscreen. Into that, enter

xfce4-terminal

This will open an xfce Terminal that you should have no trouble right clicking in and enabling menubar - then going from Menubar to Edit > Preferences.

You can also type (I cannot remember which) either “Preferred” or “Default” on the app menu search to pull up your Default Applications or Preferred Applications interface where you can select your Terminal to default to xfce4-terminal.

Thank you both! Somehow I had unintentionally uninstalled xfce4 terminal, which is why I couldn’t find it. Since xfce terminal shows up twice in Software (see screenshot), I may have uninstalled it thinking it was a duplicate.

But now I’ve installed xfce4 terminal from the software database, which looks much better and does exactly what I need! Thanks again!

1 Like

I Think… it shows up twice because one up is for the xfce4-terminal and one is for xfce4-terminal-preferences.
It probably shows up twice like that in your app menu too- It does in mine and it drives me crazy because it is not always clear which is which. Fortunately, the common keyboard shortcut to open terminal saves the day. But on occasions where I wanted to manipulate the app menu, that issue became a thorn in my side.
It had not occurred to me that it might present a similar problem in software (I never use the software channel, so never noticed.)