There's an error in 'sudo apt update' . Please anyone help me fix this. I'm new to zorin/linux

jeba@jeba-Not-Specified:~$ sudo apt update
[sudo] password for jeba:
Hit:1 Index of /ubuntu focal InRelease
Hit:2 Index of /zorinos/apps/ubuntu focal InRelease

Err:13 http://kw.archive.ubuntu.com/ubuntu focal-updates InRelease
Could not connect to kw.archive.ubuntu.com:80 (212.43.0.68), connection timed out

W: Some index files failed to download. They have been ignored, or old ones used instead.

I've deleted many http links from the above code I got due to restriction of 5links for new users

The message is telling you that kw.archive.ubuntu.com is currently down. Try again later.

BTW, post support questions in #general-help.

can't I change it to another server?? I tried to set it on main server but still getting same error.

Yes, open Software & Updates
From the Download From, on the drop down menu, select "Main Server"

Reboot and check by running "sudo apt update" in terminal again.
If it is still showing kw.archive.ubuntu.com
We can edit your sources.list to change it to
archive.ubuntu.com

Moved to General Help.