ThinkPad and monitors not going to sleep

Hi guys,

For the last week or so, my ThinkPad X1 Extreme and external monitors are not going to sleep when the system is inactive. Here is a screenshot of my current power settings:

Any ideas as to the cause of the issue?

Thanks in advance for any and all help, you guys are the best.

Gday @Shema , Is this dual boot?
If you have windows still on the machine,
I would suggest you check the power options. Goto Control Panel/Power Options. On the left Side, there should be an option to "Choose what happens when lid is closed". Click on that, and select what you wish to do when you close the lid. ( "Uncheck fast bootup" ).

Does the machine sleep without power plugged in?

Hey Ocka, thanks for your reply. No, I'm only running Zorin OS — Windows is long gone. :slight_smile:

I just ran a test on battery power and it doesn't sleep there either.

1 Like

This Could be caused by let's say a new app installed, or updates, etc..
So think back as some app's think they know better & change, setting. :smile:

Try turning off fast boot in BIOS,

If you have the option to control " What happens when you close the lid" ( Uncheck, " fast boot" after hibernation.) maybe in Setting>Power?

Ok i just learnt something new, try this link, may help.

Take Note about the SWAP partition.

Thanks for your help, Ocka. I ran some Lenovo updates and things seem to be working again...

1 Like

@Shema , Your welcome.

Please Mark this Topic as " Solution " to let others know,Thank you.