ThinkPad "X330" Does Not Suspend When Lid Closed

I have a pretty good idea of why it's doing that. On the "X330," the display is technically an external display. My understanding is the connector is soldered to one of the docking station port's DisplayPort lane. The internal LVDS connector is disabled by 1vyrain.

I had the same problem in Mint but there, I was able to solve it because it included an option in power settings to suspend when connected to an external monitor. It's an option in Elementary OS as well but I decided against using it because I didn't want to take the time to get used to the more MacOS-like UI.

So far, the only solutions I've been able to find seem to be for the opposite of what I'm trying to do. Does anybody have a solution to this? Thank you.

EDIT: For anybody asking why I left Mint, it's because for some reason, I could not get the TrackPoint sensitivity to work properly on that distro. It works fine in Mint on my T410, T430, and T15g but not the X330.

1 Like

You may be able to achieve this using dconf-editor.
Install if you do not have it:

sudo apt install dconf-editor

Open dconf-editor and navigate to /org/gnome/settings-daemon/plugins/power, then scroll down to lid-close-suspend-with-external-monitor and flip the switch to On or True:


You can install gnome tweaks

sudo apt install gnome-tweaks

Then look for tweaks in the app menu.

You may want to open your startup applications app and check to make sure that there isn't a listing for disable laptop lid switch booting with the os..

You may want to look at the top x+1 things to do after installing zorin in the tutorials section of this forum. Tlp is great for extending battery life and has an option there as well for the lid switch i believe.

1 Like

Welcome to the forum

Forgot to mention that I tried Gnome Tweaks. There was not an option for suspending with the lid closed, unfortunately. There's nothing in startup applications either that disables laptop lid switch booting. It's just im-launch, Indicator-LockKeys, Psensor, and SSH Key Agent. Was worth a shot, though. Thanks.

I thought that would be the answer but unfortunately, it does not appear to be the case. Even with that turned on, something is preventing it from suspending with the lid down. Dang it.

Try the power settings. If not there, definitely install tlp... there should be a setting in there. There was one in general settings i believe, but i don't recall because i use cinnamon regularly, not gnome

There is nothing in power settings about suspending it while attached to an external monitor. Don't see anything about it in tlp either. Is there an option about that in power settings in Cinnamon?

Oh. What happens if you flip it back to True, then?

One last possible place to check, is go to privacy tab in settings. Then on the Seenlock category, look for any settings in there that might help. I am not exactly certain what the issue is at this time. Not sure if its a bug, or a setting in there, or an issue with hardware itself.

Still unchanged. Very puzzling. Flipping that switch in settings while running a live boot of Mint and Manjaro works. Worth a try, I guess. Looks like I may have try another distro. Shame. I've come to like Zorin about as much as I like Mint.

EDIT: Never mind. Doesn't work in Elementary OS. Puzzling.

Unfortunately, none of those did anything either. Different distro time, I guess.

It can happen - or begin to happen - on any distro.
Try the steps outlined here:

Still didn't work. Dang it.

EDIT: Dang it. I hoped installing the KDE Plasma environment would do it. It includes the switch but that ended up not working anyway. Really not sure why it's doing that. It works on the Kubuntu live boot I ran.

Did you run sudo systemctl restart systemd-logind.service after performing the above?

Yes. It didn't do anything, unfortunately.

1 Like

Really is an exchanging one problem for another situation here. Closing the lid works in Kubuntu but I can't get the dang fingerprint reader to work anymore. Don't feel like trying with Manjaro yet so may give Zorin another try anyway. (Outside of the funkiness with the lid closing issue, I like it more than Kubuntu.) Maybe if I do that on a clean install, it will work. Will give that a shot.

It may well be that a clean installation might work. Things can surprise you. Does the fingerprint reader work in Zorin?

Tried dconf-editor in a live boot. It did not work. Worth a shot, I guess. And yeah, the fingerprint reader worked out of the box in Zorin. Really liked that about it. (Also did in the Ubuntu live boot I tried.)

Gnome Blocks suspend when an external Monitor is detected:

systemd-inhibit --list --mode=block
Who: $USER(UID 1000/$USER, PID _____/gsd-power)
What: handle-lid-switch
Why: Multiple displays attached
Mode: block

Can you please run systemd-inhibit --list --mode=block in terminal and relay the output?

The patch for this is supposed to be here:

But isn't.

You said Kubuntu works? Which is KDE desktop, not Gnome.
I wonder if you might (just to try it out) test this with a LiveUSB of Zorin OS 15.3 Lite which uses XFCE desktop, instead of Gnome Desktop. Sorry to put you through this much trouble.