ThinkPad "X330" Does Not Suspend When Lid Closed

In the 15.3 Lite live boot, it says

In the 16.0, got what you posted.

OK... in 15.3 lite LiveUSB, can you test this?
Set the settings in xfce power manager, then close the lid.
Login on LiveUSB is user: zorin pass:______(blank)

https://docs.xfce.org/xfce/xfce4-power-manager/preferences

Otherewise, these commands on Zorin OS Lite will work on XFCE desktop (Which is what I use):
Suspend Key:
xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/logind-handle-suspend-key -n -t bool -s true

Lid:
xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/logind-handle-lid-switch -n -t bool -s true

the above may require you to install power manager utilities. I am reasonably certain this comes included in Zorin OS Lite, but not 100% certain, so just in case:

sudo apt install pm-utils

That ended up still not working. Have it set so the laptop suspends when the lid is closed. Installed pm-utils and used those commands. Still nothing. In trying out a few other distros, it works in PureOS Plasma but not PureOS GNOME. Tried using dconf-editor in Pop!_OS. Didn't work there either.

Ok, so it works on Plasma Desktop, (KDE - Kubuntu, PureOS) but not in Gnome.
It also does not work on XFCE.
So it may be a GTK thing. At least we are narrowing it down.

1 Like

Tested on Solus as well. It works on Plasma but not GNOME, MATE, and Budgie. Trying out Manjaro right now. Liking it alright but am not quite used to the different terminal commands. Am waiting to see how Fingerprint GUI works. Currently building right now.

EDIT: Friend pointed out a potential solution for Manjaro but I separately figured out how to get the fingerprint reader working in Kubuntu. Back to that now.

1 Like

Holy smokes. Fingers crossed it's not something that just works in the live boot but I tried Mint with MATE instead of Cinnamon. The TrackPoint speed works fine and even without the option to suspend while an external monitor is plugged in, it goes to sleep properly. Might be a Mint thing with MATE because it didn't got to sleep properly on my live boot of Solus MATE. If the fingerprint reader works too and doesn't freeze on the login screen like in Kubuntu, I will be in Linux heaven.

Edit: Tested Mint MATE on an external hard drive. It works! It all works! Fingerprint reader and lid closing!

Awesome. Nothing like getting everything working to feel like you can get working.
Many of us are Mate or Mint users (I have Mate, Cinnamon, XFCE, LXDE and Enlightenment Desktops at my disposal) so feel free to use this forum for further troubleshooting.

1 Like

Was dissatisfied with how I couldn't organize the icons on the panel/taskbar in Mint MATE. Ended up switching back to Kubuntu. Figured out how to get it to not freeze on the login screen with the fingerprint reader enabled. Last post on that thread suggested replacing SDDM with Lightdm and it worked! Hopefully, this will be the end of all my distro hopping.