Thunar not creating .pdf thumnails

Thunar shows thumbnails for all file types except for .pdf
I have Installed tumbler and its not showing and I think I might have mistakenly deleted the thumbnails folder in the file manager because I can't seem to find any such folder while I search with catfish file search program.
but I found a folder named thumbnails in .cache folder

Have you installed:

sudo apt install tumbler-plugins-extra

yes..

I needed to check since that is a separate package from installing Tumbler.

Is it all pdf's or just some pdf's?

Its for all pdf files.

Try

sudo nano /etc/apparmor.d/local/usr.bin.evince

Add the line

owner /tmp/{,.}tumbler-* w,

tap ctrl+x to exit, then the y key to say yes to save, then the enter key to save as current configuration.
Log out, then in to test.

1 Like

unfortunately it did not work.

There are two standing bugs- that is one of them.
The other has to do with how .pdf files store and display their thumbnail images. This relates to how it is all set up for Windows.
I do not know how to fix that one, so at this point, we are both stuck.

1 Like

ok thanks, will installing some other file manager work or no choice only clean install?

I prefer and use Nemo File Manager on Zorin OS Lite (XFCE)

sudo apt install nemo

You can also install another that you may prefer:

sudo apt install nautilus

sudo apt install spacefm

and so on.
As they use a different method of managing thumbnails, one of them may resolve the issue. Good idea thinking of it.

1 Like

thanks, will give it a try

In nemo at first only some of the pdf's thumbnail got generated but I had to change some preferences in the setting that is to set the ""only for files less than" from 1 mb to 100mb.
Thank you now I am able to get all thumbnails but I noticed some thing, Will installing nemo also install kde connect because I see kde connect installed after installing nemo?

1 Like

No, what you saw installed was the kde-connect extension for Nemo File manager to allow Nemo access to transferring files with KDE Connect.
I use Kde Connect on Zorin OS lite in lieu of Zorin Connect, so I have been through all that already on my end.:wink:

Moved solution to your post as that is what provided the actual solution.

2 Likes

oh, I confused. Could you tell me how to uninstall thunar and to set nemo as the default one because I have a very low storage already?

You can set Nemo as default using the Default apps:
Start with Settings > default applications > Utilities > File Manager: In the drop down menu, type in nemo

Sadly, you cannot remove Thunar as it is integrated into the desktop. However, removing it would actually not free up much space.

1 Like

Thanks :upside_down_face:

1 Like

also, Is it advisable to remove Evince document viewer as it is default one in Z15.3 lite? I use okular and pretty much used to it & like it more than evince

Actually... It is one of the first things I remove. :grin:
I cannot stand evince.

You might run

sudo apt clean && sudo apt autoremove

regularly to keep storage clear.

If you find a package you do not use listed in your apps and you want to remove it, just be sure to read the terminal output of what it will remove with it.

2 Likes

Thanks again, I am also not a fan of evince.

Last thing to ask, The appearance of the nemo file manager quite bothers me as you can see it below

The big sizes of the move forward and move backward buttons and the small size of the icons in the side panel and folders

Does it actually look like this?

Yes... that annoys me, too. The big icons are fine. The tiny ones bother me.
I adjust this on my own system with a custom .css and icon theme.
I am also cruel enough that I do this to any person who uses one of my themes and icon sets by including this customization in my themes gtk.css

But you can also remove those larger icon buttons from Edit > Preferences > toolbar
In View, you can uncheck the Statusbar

2 Likes