Touchpad disabled after sleep

Just installed Zorin 17 Pro on a Thinkpad Carbon X1 Gen3.
When laptop goes to sleep (time/close lid), the touchpad gets disabled. Only solution so far is to restart the computer.

Is there a known solution to this issue?

I searched and found some proposed methods using xinput, but it seems this can not be used as devices are listed as xwayland. Any enable/disable commands don`t work.

I have been running Zorin 16 and lately 17 on a Thinkpad T460s until now with absolutely no issues whatsoever.


In your BIOS Settings, ensure the touchpad is set to "Windows / Linux" and not set to "S3 Linux".
Once changed, reboot and test...

Thanks for your reply, @Aravisian.

I have no such setting in BIOS.
BIOS v. N14ET56W (1.34)
Dated 2021-08-31

The laptop has been running Windows until recently, and I think updates has been performed as per Lenove Vantage/MS updater.

I think I found a fix, it works well waking from a forced suspend.

Lenovo Thinkpad Carbon X1 Gen 3, running Zorin 17 Pro

Make script (.sh) in /lib/systemd/system-sleep folder

Initial problem, could not save to this folder from gedit editor.

My steps:

  1. Using gedit (any text editor will work) created file in $home
  2. Script

case "$1" in
          sudo modprobe -r psmouse
          sudo  modprobe psmouse

exit 0

  1. Moved the file to location
sudo mv /lib/systemd/system-sleep
  1. Set privilege
chmod +x /lib/systemd/system-sleep/

The script is based on solutions provided by users "maruf" and "Lilly-R B" here:
Reset Touchpad
Excute script from suspend

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.