Touchpad Issue Lenovo Notebook Zorin os 15.3 core


I have been having the problem with my notebook “Lenovo ThinkBook 14 20SL0032GE i5-1035G1” that the touchpad dosent work after the installation of Zorin os 15.3 core.

After communication with Zorin Support, i tried this repo:
sudo add-apt-repository ppa:kaihengfeng/lp1853277

And a new kernel
sudo apt install linux-headers-5.4.0-49-generic linux-image-unsigned-5.4.0-49-generic linux-modules-5.4.0-49-generic

But thats couldnt help my problem and we didnt reach to any soloution.
Any help?

Best regards,

You may need to check whether your touchpad uses elan or synaptics.
There is a current bug report on this issue.

It appears that your steps are correct. You did everything right. The repo and the package appear good.
However, there may be one additional step needed:

Please try applying this patched kernel (Install the .deb package) then reboot and boot into it. Let us know what happens…

Hello Aravisian,

Such a brilliant answer, the touchpad works now after installing the dep and updating the grub.
I will do some tests to make sure that this soloution isnt temporary.
Then i would close the topic.

Thank you so much and best regards,


i write this reply to assure that the soloution is fixed and works 100% after testing.
The topic can get closed.

Thank you and best regards,

1 Like

Shaker, you are welcome and welcome to the forum. Glad to know you got it sorted out. :slight_smile: