TouchScreen rotation reversed x-y

Depends which way round I do this, when the screen is portrait, the mouse pointer on the touch screen is correct but the touchpad isn't i.e up is right/left is down.

When the screen is in landscape the touchpad is correct but touchscreen is inverted.

Thanks for the tip on Nano :+1:

1 Like

Ah, this is helpful.
What I can find is- this persists across Gnome or XFCE. So it really seems to center on xinput.
You might try (as the simplest approach):

sudo apt install --reinstall xserver-xorg-input-evdev

sudo apt remove xserver-xorg-input-libinput

If that does nothing - you can easily reverse it:

sudo apt install xserver-xorg-input-libinput

1 Like

Goto → Settings → Devices → Displays and clicking on the "Orientation" setting, set it to "Landscape"

It maybe that in startup the screen calibration is running(detecting & setting up). as you have it in portrait, it maybe not detecting the full screen, this maybe causing the inversion etc,

Also opent "Startup apps" & make sure touchscreen calibration is in the list.
Also check keyboard config/language/etc.

Try the calibration setup.

If still no luck,
Try removing iio-sensor-proxy,

sudo apt remove iio-sensor-proxy

reboot & try.

1 Like


BlockquoteYou might try (as the simplest approach):

sudo apt install --reinstall xserver-xorg-input-evdev

sudo apt remove xserver-xorg-input-libinput

Didn't do anything so I reversed it.


I couldn't find settings that said "Landscape" the only option was in display where I could rotate right, left, horizontal. Are there other settings? I looked into startup apps and couldn't see touchscreen calibration, could you elaborate on the calibration setup?
I then removed lio-sensor-proxy but that made no difference, I thought it best to re-install it but when I did the output was...

BlockquoteThe following NEW packages will be installed
0 to upgrade, 1 to newly install, 0 to remove and 0 not to upgrade.
Need to get 35.8 kB of archives.
After this operation, 171 kB of additional disk space will be used.
Get:1 Index of /ubuntu focal-updates/main amd64 iio-sensor-proxy amd64 2.8-1ubuntu2 [35.8 kB]
Fetched 35.8 kB in 0s (166 kB/s)
Selecting previously unselected package iio-sensor-proxy.
(Reading database ... 216842 files and directories currently installed.)
Preparing to unpack .../iio-sensor-proxy_2.8-1ubuntu2_amd64.deb ...
Unpacking iio-sensor-proxy (2.8-1ubuntu2) ...
Setting up iio-sensor-proxy (2.8-1ubuntu2) ...
iio-sensor-proxy.service is a disabled or a static unit, not starting it.
Processing triggers for dbus (1.12.16-2ubuntu2.3) ...
Not sure if that has some clues.

I feel, there is an answer out there, when I was searching I came across a similar topic in the Mint forums where the touchscreen appeared to be working right out of the box. Also didn't appear to be an issue with Ubuntu, these all being Ubuntu based it's a strange one!
The search continues!

Sorry i mislead you, but you found the right place for Orientation (In Display settings) the above instructions where for Gnome. Still landscape should be an option.(stranger things have happened).

I'm not sure on the horizontal setting? is this landscape?
or is it so you can flip over the screen?

Ok lets go back a little,
1st is this dual boot?
2nd, Run a BIOS firmware update,
Also Drivers for your laptop(concentrate on screen & touchpad drivers)

When you restart, Open "Software & Updates", When it finishes it scan, Click the "Setting" button, goto>Additional Driver (Tab), see if it has any suggestions, if not then continue with the update.

Did this help?

If not, please show the results in both portrait & landscape orientation modes.
1st get the screen identifier name,

xinput -list

Example: device-id-name="ASUS TouchScreen",
Replace the below with a copy of your device-id-name.

In portrait mode run

xinput list-props "Your device Name"

Then rotate the screen so it turns to landscape, & run the above command again.

In both cases, does it say "Inverted" or "Normal"?

1 Like

Hi @Ocka no this isn't dual boot, I've just updated the bios to latest version and there are no other drivers available.

output of xinput-list
xinput -list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Asus TouchPad id=12 [slave pointer (2)]
⎜ ↳ SIS0457:00 0457:1133 id=13 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Power Button id=8 [slave keyboard (3)]
↳ Sleep Button id=9 [slave keyboard (3)]
↳ Asus Keyboard id=10 [slave keyboard (3)]
↳ Asus Keyboard id=11 [slave keyboard (3)]
↳ Intel HID events id=14 [slave keyboard (3)]
↳ gpio-keys id=15 [slave keyboard (3)]
↳ gpio-keys id=16 [slave keyboard (3)]
↳ Asus WMI hotkeys id=17 [slave keyboard (3)]

Not sure which is the touchscreen? I've also been following this post which appears to be fixed but I'm struggling to understand all of it so need baby steps :grinning:

1 Like

Given my experience over the weekend, I'd expect

is your touchscreen.


You'll have to bare with me here, I'm not that confident at this level. I'm trying to work out what you did from your post but I'm struggling to work out exactly what you did.

Did you use the calibration tool to change your settings?

@Ocka Just to be clear the screen doesn't auto rotate so I don't think that's the issue. I manually set the screen to rotate 90 left as it startsup in portrait mode.

Sorry for the delay @Moocher
So to make this clear.

  • when you rotate from profile to landscape the keypad is 90deg out of wack?
    (if you could physically turn the "Arrows" on the keypad 90deg it would be then synchronized?)

Another question:
When you use the touch screen keyboard in "Landscape" Does this work correctly? (without docking it to the physical keyboard)

So in other words does the issue only happen when docked to the keyboard?

@Ocka I don't rotate the keyboard at all, I just run it in landscape mode docked, I have rotated the screen 90 left on initial setup and it persists because initially it was in portrait mode. The issue is still there when it's undocked.
@bruceax seems to have solved it but I'm struggling to follow his instructions.

When I run the touchscreen calibration tool I get the results...

Calibrating standard Xorg driver "SIS0457:00 0457:1133"
current calibration values: min_x=0, max_x=65535 and min_y=0, max_y=65535
If these values are estimated wrong, either supply it manually with the --precalib option, or run the '' script to automatically get it (through HAL).
--> Making the calibration permanent <--
copy the snippet below into '/etc/X11/xorg.conf.d/99-calibration.conf' (/usr/share/X11/xorg.conf.d/ in some distro's)
Section "InputClass"
Identifier "calibration"
MatchProduct "SIS0457:00 0457:1133"
Option "MinX" "20582"
Option "MaxX" "20377"
Option "MinY" "52565"
Option "MaxY" "51800"
Option "SwapXY" "1" # unless it was already set to 1
Option "InvertX" "0" # unless it was already set
Option "InvertY" "0" # unless it was already set

but I'm struggling to find /etc/X11/xorg.conf.d/99-calibration.conf or know where to copy the data to.

Have you tried removing the 90deg that you have set to run at initial startup?
Does this change the result?

To locate the config file
1st run

cd /etc/X11

The run


Please post a screenshot of the results.

/etc/X11$ ls
app-defaults fonts xkb Xresources Xsession.options
cursors rgb.txt Xreset Xsession xsm
default-display-manager xinit Xreset.d Xsession.d XvMCConfig


Ok, so it would appear that the folder is in /usr/share/X11/xorg.conf.d/

but I don't see a file called "99-calibration.conf" the only files in there are


I found in this post to maybe edit the 10-evdev.conf Would you suggest that?

1 Like

Update on this, I edited the 10-evdev.conf with the results of the calibration while in sudo. Restarted the system but it doesn't appear to have made a difference.

So, as a bit of a gamble, I used thunar to create a file in /usr/share/X11/xorg.conf.d/ named "99-calibration.conf" and added the calibration to that. No change.
My knowledge begins and ends there :joy:

Gday @Moocher,
You have done a great job, (this shows you'll be a good linux user ...Not saying this is the norm, but to TRY is a good asset )

First please run a BIOS update, (BIOS>Advanced>EZ update or EZ utility.

As we see the config file is missing.
To make this easier, i would suggest reinstalling Zorin OS. After a bit of research, some say Zorin OS core seems to setup touchscreen a little better.
If you wish to use Zorin OS Lite, then please do so.

My Main point is i recommend you reinstall. Please use a good usb stick & please use Rufus to create the bootable usb stick. If possible a usb-3 stick.

Note: some old usb sticks can be damaged/faulty ( this only needs to be a few Bad sectors, Not having a config file tells me something went wrong on installation.

Remember to check the downloaded file.
Maybe even refresh your modem.