Trapped at grub rescue (urgent help needed)

Hello guys
I just deleted a ntfs partition using gparted and rebooted and this happened

@Aravisian can you help me pls
Or anyone help, its urgent

You deleted your EFI partition?

No i just deleted a nomal ntfs partition anyways i will try your solution, thank you for your reply

Yes, I think follow the above steps anyway...

Bro first thing to note
My system is not UEFI it is legacy
So what I did was booted into a live Zorin environment and installed boot repair and let it complete and rebooted it worked I can access the system now

Now my system configuration was all off (i have managed to get back everything)

But now the problem is login screen wallpaper is not changing. I have tried using lightdm setting but it still does not change how to solve that
Bro even the Zorin appearance is not launching
This is the error while launching zorin appearance through terminal

WARNING:root:Shell not installed or running
Traceback (most recent call last):
  File "/usr/bin/zorin-appearance", line 11, in <module>
    load_entry_point('zorin-appearance==4.1', 'gui_scripts', 'zorin-appearance')()
  File "/usr/lib/python3/dist-packages/zorin_appearance/", line 161, in main
    window = ZorinAppearance()
  File "/usr/lib/python3/dist-packages/zorin_appearance/", line 129, in __init__
  File "/usr/lib/python3/dist-packages/zorin_appearance/", line 70, in __init__
    self.selection_box.add(widgets.Switch(_('Icons on Desktop'),
  File "/usr/lib/python3/dist-packages/zorin_appearance/", line 70, in __init__
  File "/usr/lib/python3/dist-packages/dbus/", line 141, in __call__
    return self._connection.call_blocking(self._named_service,
  File "/usr/lib/python3/dist-packages/dbus/", line 652, in call_blocking
    reply_message = self.send_message_with_reply_and_block(
dbus.exceptions.DBusException: org.xfce.Xfconf.Error.PropertyNotFound: Property "/desktop-icons/style" does not exist on channel "xfce4-desktop"

Can you try:

sudo apt install --reinstall zorin-os-lite-desktop

and see if that restores the Zorin Appearance and lightdm?
Installing that will give prompts on LightDM in the terminal; please be sure to follow them.

bro reinstalling Zorin lite desktop gets back the lightdm wallpaper but still Zorin appearence not launching

Please try:

sudo apt install --reinstall zorin-appearance

Nope still no luck

That is worrysome...
From what we know so far...

  • you removed a partition
  • this affected Grub
  • now we see it is affecting system files...

If this was me... I would perform any necessary personal file back ups and reinstall.
Because even if we manage to solve the missing Zorin Appearance - who knows what other essential files are corrupted or missing?

NTFS operates differently than ext4 - it Fragments. That fragementation in the NTFS partition may have caused information stored on different sectors or blocks to be removed when you removed the partition, since the partitions data was fragmented all over the drive.

I am not planning for a reinstall now
I am using the system as it is for now I don't see any critical system changes

But if I reinstall I want get all my configuration (like firewall, emby server etc) and apps as it is, is there a way to achieve this ?

Save the ~/.config directory on a USB or external drive.

You may try using timeshift... then save the timeshift backup on external drive. Then reinstall - then apply the timeshift backup. Hopefully, it will restore everything and leave the reinstalled files intact. But I cannot guarantee it as I have never personally tested that.

1 Like

If you are going to use Timeshift to save to an external device, you MUST format to Ext4 - I copied my Timeshift folders to NTFS external drive and is now inaccessible!

1 Like

Roger that :cowboy_hat_face:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.