Triple Monitor not working anymore


Completely new here. I've been using Zorin OS Pro and today suddenly after upgrading some packages and getting an Latex installation running (For my study's), I got back home from University, connected laptop to my Lenovo Dock and suddenly it didn't work anymore. I'm currently only able to use 2 of my monitors (while using 1 direct HDMI cable and 1 DP via the dock (the dock is connected by USB C, I suppose thunderbolt) while disabling my laptop monitor disables automaticly. While trying to change settings I rarely get anything done, Zorin sets it back to the start settings.

While booting into Zorin, all my monitors get a loading screen and a login-screen. However when I login, they switch to my 2 seperated monitors and the laptopscreen goes off. I can't change the settings otherwise the system crashes (or might keep loading for a too long time) I then rebooted and got the same scenario.
I have a dual boot with Windows and it works fine there.
I've been searching for solutions but nothing i found could change it.

I also had this problem before in which i easily could lower de resolution and framerate of 1 of my monitors so i could use all of them. I supposse that was because my dock doesn't support 3 monitors on high resolution.

I can't figure out what I should do now. Could someone help?

Great thanks in advance for any reply!

I ran this command: "sudo lshw -C video".

description: Display controller
product: Advanced Micro Devices, Inc. [AMD/ATI]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:03:00.0
logical name: /dev/fb0
logical name: /dev/fb1
version: c3
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi bus_master cap_list rom fb
configuration: depth=32 driver=amdgpu latency=0 mode=1920x1080 visual=truecolor xres=1920 yres=1080
resources: iomemory:fc0-fbf iomemory:fe0-fdf irq:76 memory:fc00000000-fdffffffff memory:fe00000000-fe0fffffff memory:fc900000-fc9fffff memory:fca00000-fca1ffff
description: VGA compatible controller
product: Advanced Micro Devices, Inc. [AMD/ATI]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:08:00.0
version: c5
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
configuration: driver=amdgpu latency=0
resources: irq:50 memory:d0000000-dfffffff memory:e0000000-e01fffff ioport:d000(size=256) memory:fc800000-fc87ffff

NOTE: The current Laptopdisplay is disabled in the Settings Menu (Display)

I just came accross this post too and I've been wondering if there's a similar problem. Zorin with Linux 5.15.0-53-generic has AMD GPU Displayport Issues

However I'm on linux-5-15-0-60 and can only go back to 5-15-0-58, which didn't make much of a difference.

You can install a different kernel and test on it- I am not certain that is the right step to take at this moment but the option is there.

In the meantime, at any time have you set Lidswitch?

sudo nano /etc/systemd/logind.conf

For the line: HandleLidSwitch=, remove the hashtag (#) and set to ignore.
= HandleLidSwitch=ignore

1 Like

Hi! Thanks for replying so fast, I changed logind.conf. Right now I'm in class, this evening I will check if it changed anything.

Hi again, I now figured out why I couldn't use my monitor setup. I don't know what Zorin OS Wayland is. However, I quickly found this link . Seems I switched to Zorin OS Wayland in which Display set-up doesn't properly worked for me. Hence, the problem now is solved.

Thanks for your reply and time!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.