Zorin Forum

Troubleshoot WiFi

Hi. I have got a 100Mbps network connection at my home. However, the internet on my laptop (running Zorin 16) disconnects often. Also, my router is a bit old too and my laptop is Lenovo Z50-70 20354 model. How do I know which is causing the problem? The WiFi chip on my laptop or my WiFi router itself? How do I find the odd one here?

I'll be happy to provide you more information.

1 Like

try to follow the below website. that may can solve your problem

according to the above website

Step 1: Open Terminal using Ctrl+Alt+T.

Step 2: Update system packages using the following command.

sudo apt-get update

Step 3: Install the required packages using the following command.

sudo apt install git build-essential dkms

installing custom packages

Step 4: Clone the Realtek RTL8821CE Driver using the following command.

git clone GitHub - tomaspinho/rtl8821ce

Step 5: Move to the repository directory using the following command.

cd rtl8821ce

Realtek RTL8821CE Driver

Step 6: Use the following command to make the script of dkms-installation executable.

chmod +x dkms-install.sh

make dkms-install.sh executable

Step 7: Make the dkms-remove script executable.

chmod +x dkms-remove.sh

Step 8: Execute the installation script using the below-mentioned command.

sudo ./dkms-install.sh

After doing these steps restart your PC, and now you can see that the wireless network option is available.

But my WiFi chip model is RTL8723BE.

1 Like

Please post the output from lspci to make sure. You can write that in the terminal.

1 Like

Okay. Please wait

To late :crazy_face:. Open up the terminal and write

sudo tee /etc/modprobe.d/rtl8723be.conf <<< "options rtl8723be ant_sel=1"
1 Like

Yes, I did. Now the internet won't disconnect?

I bet you tell us if that happens :wink:

1 Like

Looks like it's working. No WiFi disconnect until now. I'll let you know if it happens again.

3 Likes

I don't think it will disconnect. Ubuntu 20.04 removed that part for your wifi card, we readded it.

If this fixed the issue, please mark the post that solved it.

1 Like

Oh. All right. I will mark the fix as the solution now. Thank you for your assistance.

2 Likes

By the way, for now, I see that it's not disconnecting but I see lesser speeds on speed tests. I get around 10-15Mbps even if my ISP offers 100Mbps. Before changing the antenna config I used to get around 52Mbps (both up and down).

1 Like

You can try to switch the antenna mode from 1 to 2. Easiest way is to open terminal and write

gedit /etc/modprobe.d/rtl8723be.conf

Edit the line ant_sel=1 to ant_sel=2 save and reboot.

1 Like

I think I tried this already, might have caused the disconnection problem.

1 Like

No that fixed your issue haha. We have set it to 1

1 Like

Of course. Thanks for this, but I meant antenna 2. I've created a related post earlier. This one, regarding slow WiFi speed: WLAN Speed on Zorin - #7 by capriciousduck

1 Like

The only thing you can try is ant_sel=0 which is default.

1 Like

I think I'll stick with antenna 1 - a slow internet is okay to me than often disconnects.

2 Likes

@Michel Will the setting be erased on kernel updates?

1 Like

I don't know, you also might try this

1 Like