Trying to install Totem (french public accountability software) and permission denied on line 701

Hello fellow Zorin users.
I'm trying to install the x64 version of this program and having some issues with permissions. In Terminal, I'm stuck with "permission denied line 701".
Do you have any advice ?
I tried ./ (I renamed the file) but it doesn't work properly.
Thanks for your help !

You are going to have to be more specific than that. Which file exactly did you use, and which commands did you run exactly?

Although I immediately noticed a couple of red flags about it: first of all no HTTPS, in soon-to-be 2024. Secondly, I downloaded this version which contains a whooping 700k thousand lines of code in a shell script :exploding_head:

If you can I would strongly encourage using a virtual machine for whatever this is.


Thanks for your kick answer @zenzen. I noticed your red flags, and am going to go for a virtual machine then. So I guess I will be using Wine, or Play on Linux ? I downloaded the monoposte windows x64 file, and tried to install on both, but didn't do any configuration at first neither know if I use the good tool to begin with.

I don't have any experience with Wine or Play on Linux to be honest, but my understanding is that it should work out of the box. What I've done is download that same file and double click on it, and just click "next" a few times and finally allowed executable permissions by right-clicking on the desktop icon -> properties -> permissions -> allow executing file as program.

However, nothing seems to happen when I try to run it. I can see on the terminal an error regarding Wine Mono is not installed, which I vaguely remember is something should be installed separately.
I searched through the forum and found this thread that explains how to install it. Note however that in order to avoid compatibility issues I used version 7.0.0. The reason for this is because ZorinOS 16 is based on Ubuntu 20.04 and later versions of this may not work; then again, this particular version may not work with the program you're trying to install so it's a bit of a cat and mouse game at this point.

Unfortunately, I'm still not having any luck with this. At this point I think I will step aside and let someone with more knowledge than me on this area to give you some better advice. I'll leave this post just to somewhat show what I've tried, hopefully it'll help.

I actually tried to run the other installation script that I downloaded, the one specified for Linux that I showed earlier, and I'm also getting a permission denied error even after running as sudo (administrator). Very weird way of distributing software and zero guarantees, I'll torch this VM now :smiley: :fire:

Checkout this other thread for some clues as well, it might help:

Well, thanks for everything !
I found another guide for installing Vine, which got me to install Vine Mono and get to the latest version. Did some training this way in Terminal mode. But alas, I got another error, a missing file somewhere (yes I know I'm not really enough specific, I write it by mind).
But I finally went on a PC, installed the thing and it worked !
I had to use this damn accountability program to fill a file with new data, it is done !
So subject closed :slight_smile: Thanks again and sorry for the disturb :kissing:


No trouble at all, we're all here to learn and as you see we all have to go through this process every now and then. Kudos!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.