UI lag and sound issues after installation

After installing Zorin 16 Core on a Dell Inspiron 15 3000, I immediately noticed that there is some lagginess to some UI elements like the brightness and volume pop-up sliders. Moreover, the audio is bad, it plays but it is sort of buzzing and garbled.
I checked Additional Drivers and enabled the only option: "Realtek RTL8821CE Wireless Network Adapter" but that didn't seem related and didn't fix.
Ran updates/upgrades, etc..

Any help appreciated.

What’s the output of inxi -t cm?

Can you also run sudo apt update && sudo apt upgrade and check again under Additional Drivers?

Output:
Processes: CPU top: 5
1: cpu: 1.4% command: xorg pid: 2504
2: cpu: 0.6% command: gnome-shell pid: 3260
3: cpu: 0.5% command: brave pid: 11542
4: cpu: 0.5% command: gnome-system-monitor pid: 16547
5: cpu: 0.5% command: ding.js started by: gjs pid: 31620
System RAM: total: 5.69 GiB used: 1.97 GiB (34.7%)
Memory top: 5
1: mem: 315.6 MiB (5.4%) command: brave pid: 11542
2: mem: 302.7 MiB (5.1%) command: gnome-shell pid: 3260
3: mem: 265.7 MiB (4.5%) command: gnome-software pid: 3626
4: mem: 173.9 MiB (2.9%) command: brave pid: 11646
5: mem: 165.1 MiB (2.8%) command: brave pid: 15952
and following sudo apt update && sudo apt upgrade: (same as before)
image

Output of sudo lshw -c video please?

Ran into this screen after running sudo apt upgrade -y idk if relevant


it resolved into:

The output of sudo lshw -c video:

Had you previously installed the 5.13 kernel?

As a very beginner in Linux. I don't even know the difference. I can tell you for sure that I didn't go out my way installing any kernel that didn't come installed.

Is my installation outdated or something? Thanks.

Can you please paste the output of sudo apt update?

[sudo] password for monica:
Hit:1 Index of /ubuntu focal InRelease
Hit:2 Index of /ubuntu focal-updates InRelease
Hit:3 Index of /ubuntu focal InRelease
Hit:4 Index of /linrunner/tlp/ubuntu focal InRelease
Hit:5 Index of /ubuntu focal-backports InRelease
Hit:6 Index of /ubuntu focal-security InRelease
Hit:7 Index of /stable/ focal InRelease
Hit:8 Index of /zorinos/apps/ubuntu focal InRelease
Hit:9 Index of /patches/ focal InRelease
Hit:10 Index of /apps/ focal InRelease
Hit:11 Index of /zorinos/drivers/ubuntu focal InRelease
Hit:12 Index of /drivers/ focal InRelease
Hit:13 Index of /zorinos/patches/ubuntu focal InRelease
Hit:14 Index of /zorinos/stable/ubuntu focal InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
image

Hmm this all looks normal...

The Linux Kernel is a rather basic set of drivers. It's a Large set of drivers... but basic.
Once the kernel is released by the kernel dev team, the underlying distributions must then tune and patch the kernel to their builds. Or add additional drivers. Debian, Fedora, Ubuntu... they all must patch and process the kernel, before it can properly work and be released on that distribution.
(Incidentally, this is a big part of why a user rushing off to grab the Latest Release Kernel is not a good idea. It is an incomplete product that may have regressions, missing components, etc.)
Currently, Zorin OS is up the 5.11.0-46 Kernel.

Your output shows that you are using a Higher Version than what is vetted for Zorin OS. 5.13.0-25. Which is interesting in itself, as it takes a bit of work to install a kernel higher than 5.12 on Zorin OS (Or any Ubuntu 20.04 or prior based distro) due to a bug in the packaging that Ubuntu has still not fixed.

I was thinking you may have had a Repository in your sources list that would explain the odd kernel.
But I do not see anything there.

Did you specifically install the later kernel due to your computer having New Hardware? If you rollback to booting the 5.11.0-46 kernel, does everything still work?

1 Like

I flashed the USB with the official iso. image from Zorin and I have not edited anything kernel related as far as I know. Is there some way I accidentally altered the kernel? How can I roll it back, as you suggested, to the more stable version?

What is the terminal output of uname -r?
The LinuxHeaders 5.13 listed in your screenshot may be only HWE.
Let me check the Zorin OS packages and see if that is included in the Zorin repos for some reason.

uname -r gives:
5.11.0-46-generic

YEP:

linux-generic-hwe-20.04/focal-updates 5.13.0.25.26~20.04.12 amd64 [upgradable from: 5.11.0.46.51~20.04.23]

This is in the Repository (Surprise...) I was going off on a wild goosechase.

I swear these were not there last night when I updated and did upgrades.:neutral_face:

haha no worries.
But that still leaves me in square one.
Is the solution to reinstall? or are there more troubleshooting steps?

How much RAM do you have?
What is the terminal output of inxi -G?

It says I have 5.7 GB RAM.

6 gigs RAM should be fine, for most normal usage.

Radeon Vega 3... Have you tried the Oibaf Graphics drivers?

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt update && sudo apt full-upgrade

Reboot and test...

2 Likes

Aravisian you beautiful linux beast, you got it.

1 Like

I'm dying here... :rofl:

After a wild goosechase, I finally got something right.

2 Likes