Unable to boot after Nvidia 520 update

Yesterday, I took a gamble and updated to the nvidia 520 driver via the "Additional Software" app in Zorin.

I forget the previous driver version, but it is whatever the most recent "proprietary, tested" version was.

Immediately after rebooting, I had a black screen. I have had this in the past... so I switched to the HDMI port on my motherboard, rebooted, and I actually did get to the Zorin desktop. I tried rebooting again after that, and ever since, I have been stuck on this image:

I've tried holding down Shift or c on boot to get to Grub... I remember in the past there was some nomodeset option that needed to be changed, and then my GPU would work again. I cannot seem to get to any screen other than what the image above shows.

I did make a Zorin install USB so I could open the Boot Repair tool. I get some error about UEFI USB when I attempt the "recommended repair"... I'm not sure how to resolve that. I did generate a Boot info file that is available at this url:


I did look at a number of related posts, but as I mentioned... I cannot boot to anything that lets me enter the recommended commands. If any one can offer advice, I would greatly appreciate it. I would prefer to not need to re-install the OS. Ideally, I just get back to booting to the desktop via my GPU.

Try tapping the esc or tab key.
The Esc key is used on EFI boot machines and the Hold Down Left Shift key is for MBR )Legacy) boot machines.

Once nomodeset parameter is added, please do not forget to run sudo update-grub before booting.

1 Like

Tapping Esc did work. It took me directly to the grub prompt. From there, I wasn't sure what to do... there was nothing but an empty prompt. Its not what I recalled seeing in the past.

So I gave the Boot Repair another try. I found the spot in my BIOS to disable CSM. That allowed me to properly run the Boot Repair. After doing that...

Yay! I was finally able to boot to Zorin with my GPU :slight_smile: I was even able to play a game without issues.

It seems like updating Nvidia drivers on Zorin (or probably linux OSes in general) is always a gamble. My guess is that updating the driver can maybe change the grub settings? Or a previous setting that was once required then breaks with a new driver?

Either way, I'm happy to have this behind me. Thanks for the help!


The latter can happen, yes. But the Nvidia Drivers do not change anything in grub.

Graphics in general seem to be a little bit of a gamble... I would think that Intel and AMD would be easier than Nvidia. Nvidia has a long history of hostility with Open Source. Yet, the situation with Nvidia has improved a bit.
And it seems like certain Intel Graphics within UHD and Iris XE are more problematic than Nvidia these days. At least Nvidia you can change drivers or try the Nouveau easily enough.

Might be a gdm issue, i got one a few days ago and rebooted my machine just fine.

That being said did you see the loooooong list of new NVIDIA drivers that just came out in the latest Zorin Up Dates .... at least then were in my update list today ..... see if I can find the list ..... I now take screenshots of ALL the updates I download so I know what I can remove when things go sideways .....

I just loaded the Nvidia 520 Proprietary Tested driver.
What a mess.
It broke - Everything.
I ended up falling back to display defaults and Nouveau.
I tried three times, all unsuccessful.

It took me about an hour to fix everything.

I then tested the 515 and 520 Proprietary and had slightly better results... But they both had issues. Conky would no longer display, for one...

I reverted the the 510 Proprietary that I have been using until now.

But as it stands... I do not recommend the 520 Proprietary Tested Driver.

1 Like

Works fine on Fedora with kernel 6.0.x, so it must be an ubuntu thing.

1 Like

Or the 5.15 current kernel.

1 Like

Thanks for that post Aravisian ..... I just made a post asking about 520 before I read this one .... I'm using 515 Proprietary on Zorin 16 Pro with no problems YET ..... but this morning my laptop just installed 16.2 so we will see that happens .... if it screws up I can either go back to 16.1 or drop down to 510 Proprietary ..... we'll see ..... :thinking:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.