Unable to change HDD files/HDD is detected as an external drive

I have a Lenovo ideapad S340 with Zorin OS 16.1(if that makes a difference). It has a 120gb SSD and a 1TB HDD. I run everything from the SSD but the HDD is recognised as an external hardrive. After an update, I can't even do anything to the files in the HDD. I can't change or make new files, and to access, I have to copy everything over. I looked elsewhere and someone told me to change permissions for user but that didn't work either.

Question: How do I access all my files normally(i.e. read + edit) and make Zorin detect it as an internal drive. I am okay with complicated steps as I am adequately adept. Would prefer to copypasta commands if required.

What file system is the HDD formatted in?

NTFS all the way.

Can you check if the ntfs-3g package is installed on Zorin?
Just trying to install it will tell you if so, and it will add the bonus of setting it as Manually installed if it is:

sudo apt install ntfs-3g

It have me the message that it was set to manual, but the filesystem type is now "fuse". I can copy stuff out of the drive now but still no changes or new files added.

Have you checked if you have Ownership of the Drive?
If that checks out, you may need to adjust your /etc/fstab file.

1 Like

Perfect. That worked. Thanks a ton for sending that link.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.