"Unable to lock" error, External Monitor blank

I'll create a new topic if needed but I actually have one more problem. I am using a Laptop with an external Monitor connected (Laptop lid is closed I only use External Monitor), everytime I turn it on after entering my password i get an error saying "Unable to Lock, Action was block by an application" and the screen goes black after 5 seconds (it hibernates) then each time I have to open the laptop lid press a few keys till it gets on again and then it starts functioning.

Any solutions on this please?

Are you running VirtualBox or VM ware?

Nope, I installed it Regularly. (No Dual-boot either)

Do you have the lidswitch ignored?

This is a known (and old) Gnome Shell bug that is pretty well documented (Gnome claims it is an X11 bug, but no other D.E. reports this error, only Gnome.)
https://bugzilla.redhat.com/show_bug.cgi?id=1369880

1 Like

Can you please tell me how to check it? I don't know tbh :frowning:

sudo nano /etc/systemd/logind.conf

Arrow key down to #HandleLidSwitch=suspend
and change two things: remove the hashtag and change suspend to ignore. It should look like HandleLidSwitch=ignore
Once done editing, tap ctrl+x to exit, then the y key to say yes to save, then the enter key to save as current configuration.

Reboot to test...
(Or run systemctl restart systemd-logind.service)

1 Like

Checked it, It Worked!!
Thanks Again for the Help! <3

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.