Unable to use extensions or change appearance

What if you change from Zorin Desktop to Zorin Desktop in Wayland? You can change it on lock screen, on the low right corner there's a gear button where switching to another DE.

Can you configure extensions on the Gnome website?
https://extensions.gnome.org/local/

Nope its all off, when I turn them on and refresh the page then they switch back to off

I don't have the gear icon in my lock screen so cannot switch it to wayland

Can you please run:

sudo apt install --reinstall zorin-os-desktop

Reboot and test.
If still no good, a faulty config file may be causing issues.
NOTE that performing this will set all your preferences to default. You can undo it by restoring the backup you are about to make:

mv ~/.config ~/.config-bk

Reboot and test. You can restore the above by removing the new ~/.config directory and renaming ~/.config-bk to ~/.config

1 Like

tried that and didnt work, also did not restore the config files :dotted_line_face:

it is just a matter of file naming. If it did not seem to restore your configs, please check that you typed everything correctly.

Tried... Which?
One? The other? Both?

i made the backup file first then reinstalled zorin-os-desktop then after seeing it didn't fix my layout issue I renamed the config backup file and deleted the previous one then restarted again, but it did not restore the previous config

Your personalized configs are stored in ~/.config
If you move the file to ~/.config-bk then it is backed up. The files all remain in place.
They are not deleted. They are just in a folder that is named differently than the name .config which the system is looking for.
If that somehow went sideways; restoring becomes a matter of redoing your personal settings. It's not major or dangerous to the system; just a Computer Annoyance.

RE: extensions all disabled and appearance settings grayed out:
Reinstalling Zorin-OS-Desktop should have done this, but let's try being more specific:

sudo apt install --reinstall gnome-shell-extension-zorin-dash

yeah I redid all the configs.

Also just to clarify only the extensions are greyed out and disabled. The appearance layout does not change when I change the settings.


Also I cannot see my desktop icons

and the command did not change anything after rebooting, still the same issues.

All of these describe Gnome Desktop or Gnome-Shell issues.
I am quite surprised that the --reinstall zorin-os-dekstop did not work.

You might try:

sudo apt install --reinstall zorin-appearance-layouts-shell-core zorin-appearance-layouts-support zorin-appearance

still didnt work, I've also noticed the zorin built in extensions are off and greyed out

Maybe some apps are broken or a partial upgrade happened. Let's try:

sudo apt-get update --fix-missing

sudo dpkg --configure -a

both of them did not work :frowning:

Can you give us any details on anything you were running, trying to configure, something you were installing or anything that you removed prior to the desktop reaching this state?
If you used the terminal, you can read your history from the ~.bash_history file in your home directory or directly in terminal with the command

history

If you use zsh or fish, you will need to reference that history file instead. I would reference ~.zsh_history instead on my computer.

For looking at all dpkg history, you can check /var/log/dpkg.log where the date of the action precedes the action in the file. Most recent will be at the bottom of the file. If you have in mind a date when all this began, you can examine what was upgraded, installed or removed in the range of prior to that date.

At this point, I am at a loss and wondering if reinstalling Zorin OS is your only option. Hopefully, the logs above may provide more clues.

Have you tried any other layouts?

Are the extensions disabled in the other layouts?

changing the layouts in the appearance does not change the desktop layout

only notable thing was me reinstalling Thunderbird and resetting my Bluetooth because it stopped working properly. This is my dpkg log DPKG Logs - Pastebin.com from August 12, I didn't see any noticeable change or edit.

I am seeing an absolute ton of:

status half-configured

listings in your pastebin. It looks as though packet loss or network outage interrupted most of the essential Gnome files.
Can you please check this thread to see if the issue there may also be affecting you?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.