Unable to use wifi Zorin on a surface go HELP!

Hello I just installed Zorin OS on my Surface GO. Everything went great EXCEPT the Wi-Fi is not working. It shows up but it does not find any networks it just loads for infinity. I have looked up tons of help articles and nothing helped. If anyone has any suggestions please help!

I had this issue when I tried to install zorin on my lenovo flex 5 IdeaPad. When I tried to do the nivda drivers it didn't like my wifi card. But if I did the top option of just installing Zorin, it found my wifi driver and card.

I did pick the top option still no luck. Thanks for the input glad to know I am not the only one.

1 Like

Sounds good. Hmm I have no idea then.

After a bit of a websearch using "Surface GO Ubuntu 20.04 wifi" I found this.

@zabadabadoo thank you!!!!! I will try this out and let you know what happens!!!

@zabadabadoo Can you guide me on how I would do this I am unsure.

I will not be much help as I only did a websearch. Maybe someone else can assist you better. I will flag to @Aravisian for starters.

It is easy. Just download the .zip file here:

Hit the green button Code and choose download zip.
In your Downloads folder, right click it and choose "extract here."

Now, elevate to Root:

sudo -i

nautilus

Open the downloads folder, then the ath10k-firmware-override-main and copy the board-2.bin file.
Navigate to "Other-location" from the left pane, then "computer" then to lib/firmware/ath10k/QCA6174/hw3.0/ and paste the board-2.bin file there, replacing the original file.
Repeat this for board.bin

Reboot and test.

2 Likes

@Aravisian This worked great thanks for your directions! Hopefully this helps many others!

1 Like