Unreal Engine Editor on Linux

Hi,

I want to use the Unreal Engine Editor on my Linux computer, however, I can't do that without first installing the Epic Games Launcher, which is not compatible with Linux. I tried to get it to run on Linux using Wine, but I run into this error every time:

Screenshot from 2022-07-23 10-50-30

Which is super annoying and a serious barrier. Can anyone please help me on this?

This is also a known issue on Windows from what I can read. The solution for this is

  • install the latest version of the Epic Games Launcher
  • Run Epic Games Launcher with Admin privilege
  • Install latest Microsoft Visual C++ Redistributables
  • Install .NET Framework 4.8
  • Assign Full Control permissions to the target folder
  • Modify Epic Games Launcher Target parameter: -SkipBuildPatchPrereq

How to archieve this in Wine I have no idea, as I won't torch it with an ugly stick :wink:

EDIT: if you're using Lutris they say this command will fix it:

WINEPREFIX=~/Games/epic-games-store WINE=~/.local/share/lutris/runners/wine/ge-protonified-4.9-x86_64/bin/wine ~/.local/share/lutris/runtime/winetricks/winetricks dotnet48

source:

1 Like

I tried running that command and I got this:

Screenshot from 2022-07-23 11-18-06

Unless I actually have to open Winetricks

You got Lutris installed and running? That command will only work if Lutris is installed. Also check if the paths is correctly set.

I've got it installed before I ran the command.

You need to install wine in Lutris itself and Epic Game Launcher as well.

How am I supposed to install Wine in Lutris? That's impossible.

AFAIK Lutris uses Wine, so it may be installed. Note: I don't use these apps so I have to go with my guts.

What does that even mean?

AFAIK = as far as I know

So what now?

Did you install Epic Games via Lutris?

I just installed it via Epic's download page.

I guess we need someone with expertise in Lutris to step in as I don't know how it works.

Have you checked:

It comes with a installation script.

I was able to get Epic Games Launcher running and installed Unreal Editor alright, but it crashes a few seconds after it launches. What I need is a screen recorder to show you what happens.

Blue Recorder is an excellent screen recorder.

I'm wondering if this work for Unreal 5 engine getting it work natively in Linux:

I can't upload a video - This forum doesn't let me upload videos, only pictures.

I'm using youtube for that. Just set the uploaded video so that only those who got the link can see it.