UNRESOLVED - Something to think about - printer

Thank you sir but I use WiFi to print not a USB cable ....

Thanks .... I'll go back in and try that ..... with all the tinkering I have done in those printer settings I get confused .....

Ok the problem for now seems to be solved ...... how it was solved I don't really know ..... I am giving swarfendor437 .... the nod as the last thing I did was enter this in the terminal and proceeded from there again .......

sudo system-config-printer

I completely removed CUPS (after making sure CUPS wasn't attached to anything else ..... and it wasn't) then I tried all kinds of stuff from removing CUPS ability to auto install any drivers ..... but we shall see on that one ..... I found some old posts from French Press after Aravisian mentioned if she was here she would most likely know about printers ...... I then reinstalled CUPS again and again while changing things in the terminal command swarfendor437 gave until something clicked ....

I have taken photos of all the different settings that are in the present printing settings that worked for future reference ....

I hope to god I never have to do this again as I have spent days and days 8-10 hrs a day searching for answers to this problem and even now I don't have any idea what actually worked .... but it is working as of right now ....

I would like to thank everyone (to many to name) for all the input and help that was offered both presently on the board and post of those who are not .....

..........................................................THANK YOU ......................................................

3 Likes

OK this time I do give up .... just tried to print again and same old BS .... so I went back to windows and it prints just fine ..... so to keep from getting aggravated .... when I need to print I'll load it onto a flash drive and print on windows .... I have no more patience with this garbage CUPS .....

That is really dissaponting end result, especially after all your time and effort. The battle may be lost but I suspect the war with your printer is not over. Regroup and come back when you are ready for another attack.

I have done some more searching, now we know you are wifi printing.
Found this, which is a general checklist, but may help if something overlooked.

There are lots more FAQ's on Brother Phillipines website.
This one relates to CUPS and CentOS but may give some clues.

More:

Maybe @Aravisian can cast his eyes over the above links, to see if any show any promise to cure the wifi printing.

EDIT: Lateral thinking: Could the problem be due to the Firewall (Gufw)?

1 Like

I like the way you are thinking.

They all have potential. But I wish I was adapt as you wish I was.

Printers are my weakest subject. Like Floral arrangement.

1 Like

@Aravisian I noticed you have found something on "Zorin Help".

I gave up on wifi printing even on Windows to my Epson printer years ago and stick to physical USB cable. As for wifi printing on Zorin, don't look at me is all I can say :thinking:

I wifi print all the time, on new machine, old machine, notebook - never had any issues at all..

Thanks for the responses guys at least I have an option to get the printer to work maybe not the bast but at least it will work in Win 10 ....

I went over all the settings this morning and matched them against the photos I took yesterday and the only thing I see different is that under the Printer Properties it says ....

Printer State .... - Unable to Locate Printer ..... where as yesterday it said - idle Processing .....

So it looks like it can't find the printer ??????

zabadabadoo ..... I will read all those links you posted ...... thank you so much

After reading all the info supplied by zabadabadoo ..... well all except the part about hooking up my printer with a USB cable .... as I would have to to take my laptop to the printer and hook it up ..... or run a USB cable across the the living room floor .... far easier to just boot into Windows .....

I did manage to get the printer to go from "Unable to Locate" to "Idle" like it was yesterday .... but now when I hit print test page it says Printing and 5 sec later it says Printing Completed ..... but nothing was printed .....

OK I tried following the Zorn tutorial on how to set up your Brother Printer ..... it didn't work for me because it was for printers being hooked up by way of a USB Port ..... mine is set up by means of WiFi ..... here are the results .....

All that work and I didn't save the results from the terminal ..... :sob: :sob: :sob: :face_with_head_bandage:
so it looks like I gotta do it all again tomorrow .... I did take a few photos .... were oh were did I hide that Bottle of Jose Cuervo ..... "You are a friend of mine"

I put the XX's there it originally had numbers .....

1 Like

EUREKA ...... I don't believe it .... mission accomplished after 5 days and countless hours of searching and suggestions from the board members I have a printer that prints from Zorin ..... and I'm not going to tell how I did it ..... well maybe I will as it wasn't my doing but the Zorin Brothers who solved the problem with their new ....... "Zorin Help Guides and Help" .....

Follow the instructions to the letter and know what your Host and IP address for your printer are before you start you will need them .... here is my terminal print out ..... all the contract and disclaimers have been deleted to make reading much easier and faster ....

mike@mike-ROG-Strix-G731GT-G731GT:~/Downloads$ sudo bash linux-brprinter-installer-2.2.3-1 DCP-T500-W

You are going to install following packages.

dcpt500wlpr-3.0.2-0.i386.deb

dcpt500wcupswrapper-3.0.2-0.i386.deb

brscan4-0.4.10-1.amd64.deb

brscan-skey-0.3.1-2.amd64.deb

OK? [y/N] ->y

=========================================

GPL License Agreement

GNU GENERAL PUBLIC LICENSE

Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc.51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

The precise terms and conditions for copying, distribution and modification follow.

GNU GENERAL PUBLIC LICENSE

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

Do you agree? [Y/n] ->y

wget -T 10 -nd --no-cache https://download.brother.com/pub/com/linux/linux/packages/dcpt500wcupswrapper-3.0.2-0.i386.deb

--2022-02-24 09:37:48-- https://download.brother.com/pub/com/linux/linux/packages/dcpt500wcupswrapper-3.0.2-0.i386.deb

Resolving download.brother.com (download.brother.com)... 23.78.217.63

Connecting to download.brother.com (download.brother.com)|23.78.217.63|:443... connected.

HTTP request sent, awaiting response... 200 OK

Length: 13548 (13K) [text/plain]

Saving to: ‘dcpt500wcupswrapper-3.0.2-0.i386.deb’

dcpt500wcupswr 100%[====>] 13.23K --.-KB/s in 0.04s

2022-02-24 09:37:49 (333 KB/s) - ‘dcpt500wcupswrapper-3.0.2-0.i386.deb’ saved [13548/13548]

Hit:1 Index of /deb/nordvpn/debian/ stable InRelease

Hit:2 Index of /aravisian/gtk-theming/ubuntu focal InRelease

Ign:3 Index of /stable/deb/ stable InRelease

Hit:4 Index of /stable/deb/ stable Release

Hit:6 Index of /ubuntu focal InRelease

Hit:7 Index of /aravisian/iconsets/ubuntu focal InRelease

Hit:8 Index of /ubuntu focal-updates InRelease

Hit:9 Index of /stable/ focal InRelease

Hit:10 Index of /ubuntu focal-backports InRelease

Hit:11 Index of /lutris-team/lutris/ubuntu focal InRelease

Hit:12 Index of /patches/ focal InRelease

Hit:13 Index of /ubuntu focal-security InRelease

Hit:14 Index of /apps/ focal InRelease

Hit:15 Index of /drivers/ focal InRelease

Hit:16 Index of /zorinos/apps/ubuntu focal InRelease

Hit:17 Download - Zorin OS focal InRelease

Hit:18 Index of /zorinos/drivers/ubuntu focal InRelease

Hit:19 Index of /zorinos/patches/ubuntu focal InRelease

Hit:20 Index of /zorinos/stable/ubuntu focal InRelease

Reading package lists... Done

Reading package lists... Done

Building dependency tree

Reading state information... Done

Package ia32-libs is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

However the following packages replace it:

lib32z1

E: Package 'ia32-libs' has no installation candidate

dpkg -x dcpt500wlpr-3.0.2-0.i386.deb /

dpkg -x dcpt500wcupswrapper-3.0.2-0.i386.deb /

(Reading database ... 424682 files and directories currently installed.)

Removing dcpt500wcupswrapper:i386 (3.0.2-0) ...

lpadmin: The printer or class does not exist.

Restarting cups (via systemctl): cups.service.

Purging configuration files for dcpt500wcupswrapper:i386 (3.0.2-0) ...

dpkg-deb: building package 'dcpt500wlpr' in 'dcpt500wlpr-3.0.2-0a.i386.deb'.

dpkg -b ./brother_driver_packdir dcpt500wlpr-3.0.2-0a.i386.deb

dpkg-deb: building package 'dcpt500wcupswrapper' in 'dcpt500wcupswrapper-3.0.2-0a.i386.deb'.

dpkg -b ./brother_driver_packdir dcpt500wcupswrapper-3.0.2-0a.i386.deb

dpkg -i --force-all dcpt500wlpr-3.0.2-0a.i386.deb

(Reading database ... 424679 files and directories currently installed.)

Preparing to unpack dcpt500wlpr-3.0.2-0a.i386.deb ...

Unpacking dcpt500wlpr:i386 (3.0.2-0) over (3.0.2-0) ...

Setting up dcpt500wlpr:i386 (3.0.2-0) ...

mkdir: cannot create directory ‘/var/spool/lpd/dcpt500w’: No such file or directory

chown: cannot access '/var/spool/lpd/dcpt500w': No such file or directory

chgrp: cannot access '/var/spool/lpd/dcpt500w': No such file or directory

chmod: cannot access '/var/spool/lpd/dcpt500w': No such file or directory

dpkg -i --force-all dcpt500wcupswrapper-3.0.2-0a.i386.deb

Selecting previously unselected package dcpt500wcupswrapper:i386.

(Reading database ... 424679 files and directories currently installed.)

Preparing to unpack dcpt500wcupswrapper-3.0.2-0a.i386.deb ...

Unpacking dcpt500wcupswrapper:i386 (3.0.2-0) ...

Setting up dcpt500wcupswrapper:i386 (3.0.2-0) ...

Restarting cups (via systemctl): cups.service.

lpadmin -p DCPT500W -E -v dnssd://Brother%20DCP-T500W._pdl-datastream._tcp.local/?uuid=e3248000-80ce-11db-8000-a8a7957217fa -P /usr/share/cups/model/Brother/brother_dcpt500w_printer_en.ppd

lpadmin: Printer drivers are deprecated and will stop working in a future version of CUPS.

Will you specify the Device URI? [Y/n] ->y

0: beh

1: cups-brf:/

2: https

3: http

4: socket

5: lpd

6: ipps

7: ipp

8: smb

9: dnssd://Brother%20DCP-T500W._pdl-datastream._tcp.local/?uuid=e3248000-80ce-11db-8000-a8a7957217fa

10: lpd://BRWA8A7957217FA/BINARY_P1

11: ipp://Brother%20DCP-T500W._ipp._tcp.local/

12 (I): Specify IP address.

13 (A): Auto. (dnssd://Brother%20DCP-T500W._pdl-datastream._tcp.local/?uuid=e3248000-80ce-11db-8000-a8a7957217fa)

select the number of destination Device URI. ->13

lpadmin -p DCPT500W -v dnssd://Brother%20DCP-T500W._pdl-datastream._tcp.local/?uuid=e3248000-80ce-11db-8000-a8a7957217fa -E

Test Print? [y/N] ->y

wait 5s.

lpr -P DCPT500W /usr/share/cups/data/testprint

You are going to install following packages.

brscan4-0.4.10-1.amd64.deb

=========================================

Brother License Agreement

=========================================

Do you agree? [Y/n] ->y

wget -T 10 -nd --no-cache https://download.brother.com/pub/com/linux/linux/packages/brscan4-0.4.10-1.amd64.deb

--2022-02-24 09:39:30-- https://download.brother.com/pub/com/linux/linux/packages/brscan4-0.4.10-1.amd64.deb

Resolving download.brother.com (download.brother.com)... 23.78.217.63

Connecting to download.brother.com (download.brother.com)|23.78.217.63|:443... connected.

HTTP request sent, awaiting response... 200 OK

Length: 109890 (107K) [text/plain]

Saving to: ‘brscan4-0.4.10-1.amd64.deb’

brscan4-0.4.10 100%[====>] 107.31K --.-KB/s in 0.09s

2022-02-24 09:39:30 (1.18 MB/s) - ‘brscan4-0.4.10-1.amd64.deb’ saved [109890/109890]

dpkg -i --force-all brscan4-0.4.10-1.amd64.deb

(Reading database ... 424683 files and directories currently installed.)

Preparing to unpack brscan4-0.4.10-1.amd64.deb ...

Unpacking brscan4 (0.4.10-1) over (0.4.10-1) ...

Setting up brscan4 (0.4.10-1) ...

This software is based in part on the work of the Independent JPEG Group.

You are going to install following packages.

brscan-skey-0.3.1-2.amd64.deb

=========================================

=========================================

Do you agree? [Y/n] ->y

wget -T 10 -nd --no-cache https://download.brother.com/pub/com/linux/linux/packages/brscan-skey-0.3.1-2.amd64.deb

--2022-02-24 09:39:36-- https://download.brother.com/pub/com/linux/linux/packages/brscan-skey-0.3.1-2.amd64.deb

Resolving download.brother.com (download.brother.com)... 23.78.217.63

Connecting to download.brother.com (download.brother.com)|23.78.217.63|:443... connected.

HTTP request sent, awaiting response... 200 OK

Length: 71758 (70K) [text/plain]

Saving to: ‘brscan-skey-0.3.1-2.amd64.deb’

brscan-skey-0. 100%[====>] 70.08K --.-KB/s in 0.09s

2022-02-24 09:39:37 (806 KB/s) - ‘brscan-skey-0.3.1-2.amd64.deb’ saved [71758/71758]

dpkg -i --force-all brscan-skey-0.3.1-2.amd64.deb

(Reading database ... 424683 files and directories currently installed.)

Preparing to unpack brscan-skey-0.3.1-2.amd64.deb ...

Unpacking brscan-skey (0.3.1-2) over (0.3.1-2) ...

Setting up brscan-skey (0.3.1-2) ...

enter IP address ->192.168.001.XXX

brsaneconfig4 -a name=DCP-T500W model=DCP-T500W ip=192.168.001.XXX

mike@mike-ROG-Strix-G731GT-G731GT:~/Downloads$

3 Likes

Problem NOT SOLVED ..... tried to print this morning and nothing .... checked all the settings and nothing has changed except instead of idle under ....Printer State .... it says "Processing - Unable to Locate Printer" .....

What does that mean and why would it not be able to locate the printer ????????? ..... all the settings under Printer Properties are exactly the same ....

Is there something supposed to be in the Location Box under settings ?????

Here is the one from yesterday .....

And the and the one from today ....

I see no changes except in the Printer State Box ..... both photos have nothing in the Location Box ....

I also see no place for my IP address .... should that go there .... ???????

I'm gonna answer my own post after 5 hours of searching again this morning ..... I went back and reread ALL the posts above and tried Mr swarfendor437 suggestion about using

I did have to change :80 or :8080 to :9100 and found out the last digits in my IP address were 3 instead of 2
.... so as of right now my printer is working even after shutting down and restarting numerous times ...... BUT

Now it will not print when my NordVPN is on ... it just stores the jobs in the queue until Nord is shut down and then it prints all the jobs .... I'm assuming that because my IP address has changed it gets lost again .... so it looks like I did something wrong when I set up my printer .....

Anyone with any ideas ??????????????

OK apparently it is NOT a printer problem but a VPN problem and not just pacifically to Nord according to stuff I read on the net ..... it could be cured in Windows quite easily but NordVPN it is all done by the terminal ..... so more searching is needed ....

Later .....

2 Likes

I wonder if @Frog is turning off the printer and when he switches back on it acquires a different IP address from his wifi router. i.e. Printer does not have a fixed IP address day-to-day.

1 Like

Thanks for your reply zabadabadoo ..... actually I leave the printer on all the time but I do shut off my router every night but I have been doing that for years .... printer seems to be working just fine now but my NordVPN is dead in the water .... but that is my fault as I tried to change some settings because of stuff I read on the internet .....

I read on the Nord website that there is something that can interfere with printing and your IP address .... so I deleted Nord and spent the next 4 hrs trying to get it installed again .... but no luck .... I'm going to start a new thread on that as this is one is way to long and a different problem anyway ....

1 Like

That is something I used to do, but stopped doing that after reading that it messes up your service profile with your ISP and it has to learn again. So I now leave my broadband router on 24/7, except for a reboot if I have a problem.

1 Like

OK I'm done with this Thread it has gone on far to long the problem of the printer was solved by swarfendor437 in post # 20 by using the AppSocket/HP JetDirect method .... but the Printer Properties needed to be further modified .....

After all the modifications the printer did and does still work but now it will not work with my VPN on .... I can run one or the other but not both at the same time .... which is what I intend to do for now ....

As this problem is not solved totally I will leave it as such and just abandon the Thread .... if someone feels that it is solved by all means mark it as so ....

Thanks to everyone for all you suggestions and replies .... :+1: :clinking_glasses:

2 Likes

I have added UNRESOLVED to subject line, to avoid @carmar the job.
If @Frog does stumble on a solution, then he can always come back here.

2 Likes