"Update list couldn't be updated." after searching for updates in the software store

Hello everyone,

I'm a fresh new Linux user here using now Zorin OS and I have question about the software store.
Currently, every time where I try to search for new updates for my installed programs in the software store, I get the message "Update list couldn't be updated". I can't explain myself why I get this message so I would like to know if someone can tell me more about this (and how to resolve this maybe) please? Is this a serious problem or can I ignore this because it can't for example (just a possible thought) find any new update lists so it "can't be updated"?
Thanks in advance!

With kind regards
TheBlackEye

1 Like

Can you please open a terminal (ctrl+alt+t keyboard shortcut) and run

sudo apt update

and paste the output here?

1 Like

Is your update server set to the "Main server"?
I got this error in past when I was using a local mirror server.

2 Likes

Hi. After I did that I can say that I got no error in terminal. Everything looks fine.

Here's the output:

OK:1 http://ppa.launchpad.net/zorinos/apps/ubuntu bionic InRelease OK:2 http://archive.ubuntu.com/ubuntu bionic InRelease OK:3 http://ppa.launchpad.net/zorinos/drivers/ubuntu bionic InRelease OK:4 http://archive.ubuntu.com/ubuntu bionic-updates InRelease OK:5 http://archive.ubuntu.com/ubuntu bionic-backports InRelease OK:6 http://ppa.launchpad.net/zorinos/patches/ubuntu bionic InRelease OK:7 http://archive.ubuntu.com/ubuntu bionic-security InRelease OK:8 http://ppa.launchpad.net/zorinos/stable/ubuntu bionic InRelease OK:9 https://packages.zorinos.com/stable bionic InRelease OK:10 https://packages.zorinos.com/patches bionic InRelease OK:11 https://packages.zorinos.com/apps bionic InRelease OK:12 https://packages.zorinos.com/drivers bionic InRelease Paketlisten werden gelesen... Fertig Abh├Ąngigkeitsbaum wird aufgebaut. Statusinformationen werden eingelesen.... Fertig Aktualisierung f├╝r 1 Paket verf├╝gbar. F├╝hren Sie ┬╗apt list --upgradable┬ź aus, um es anzuzeigen.

(Please ignore the different language here.)

Yes. The update server is "Main server" on my system. But it didn't changed something and I get still this error message.

Just to confirm.
Are you using Zorin 15.3 in 64bit?

Correct.

We can try this small trick to force refreshing cache.
Change the update server to the local one (Germany?) then let the updater to update cache. If this works you can either keep it to the Local or revert back to the Main.

Is this exact the wording of this error message?
Sometimes it helps to leave it to the original language for searching pps.

I changed now to a local (german) server. I get still this message.

And no, this isn't the exact wording of this error message. I wanted to make this more language friendly because I don't know how many can understand the german language.

The exact wording on my system is: "Aktualisierungsliste konnte nicht aktualisiert werden"

Can you issue this command in terminal and copy & paste the output?
cat /etc/apt/sources.list

[edit]
If you have some software from the third party installed, you might have to make a change in your sources.list
https://forum.ubuntuusers.de/topic/ubuntu-18-04-aktualisierungsliste-konnte-nicht/

Since it updates in terminal I'm wondering if it's a network issue. If you run the terminal update, does software update app then work? I've experienced this on mobile network when there was high traffic.

Here's the output:
(see screenshot; I can't paste it in text form here because the amount of '#' symbols breaks the complete text here. If you still want a text version of that please tell me, but then I have to change the text to make it readable.)

OK, thanks for your hard work :slight_smile:
You might wan to try deleting # before this line:
deb http://archive.canonical.com/ubuntu bionic partner

1 Like

Hmmmm... I remember that I implemented Flathub (source: dl.flathub.org) into the Software Store because there's stuff which I can't find without that. Could that be maybe the problem since it is (more or less) from a "third party" maybe?

I changed it now. It still comes the same message. (Or should I try a restart and try again?)

Can you try

sudo mv /etc/apt/trusted.gpg /etc/apt/trusted.gpg-bkp

sudo apt update

I am afraid I do not know much about Flatpak.
My system is so far SNAP and Flatpak free.

There is a lengthy discussion on this forum regarding those two "new" types of installers. If I cannot install with apt command, I look for deb installer at https://pkgs.org/.
If it is not there, I try to compile from the source. And if it fails, I install Flatpak and my last resort is SNAP.

2 Likes

I had no issues with the update through the terminal. It worked normally. But the Sotware Store gives me still the error message.

The output now:
OK:1 http://ubuntu.unitedcolo.de/ubuntu bionic InRelease OK:2 http://ppa.launchpad.net/zorinos/apps/ubuntu bionic InRelease OK:3 http://ubuntu.unitedcolo.de/ubuntu bionic-updates InRelease OK:4 http://archive.canonical.com/ubuntu bionic InRelease OK:5 http://ubuntu.unitedcolo.de/ubuntu bionic-backports InRelease OK:6 http://ubuntu.unitedcolo.de/ubuntu bionic-security InRelease OK:7 http://ppa.launchpad.net/zorinos/drivers/ubuntu bionic InRelease OK:8 http://ppa.launchpad.net/zorinos/patches/ubuntu bionic InRelease OK:9 http://ppa.launchpad.net/zorinos/stable/ubuntu bionic InRelease OK:10 https://packages.zorinos.com/stable bionic InRelease OK:11 https://packages.zorinos.com/patches bionic InRelease OK:12 https://packages.zorinos.com/apps bionic InRelease Fehl:10 https://packages.zorinos.com/stable bionic InRelease Die folgenden Signaturen konnten nicht ├╝berpr├╝ft werden, weil ihr ├Âffentlicher Schl├╝ssel nicht verf├╝gbar ist: NO_PUBKEY 40E0F448B35AB199 Fehl:11 https://packages.zorinos.com/patches bionic InRelease Die folgenden Signaturen konnten nicht ├╝berpr├╝ft werden, weil ihr ├Âffentlicher Schl├╝ssel nicht verf├╝gbar ist: NO_PUBKEY 40E0F448B35AB199 OK:13 https://packages.zorinos.com/drivers bionic InRelease Fehl:12 https://packages.zorinos.com/apps bionic InRelease Die folgenden Signaturen konnten nicht ├╝berpr├╝ft werden, weil ihr ├Âffentlicher Schl├╝ssel nicht verf├╝gbar ist: NO_PUBKEY 40E0F448B35AB199 Fehl:13 https://packages.zorinos.com/drivers bionic InRelease Die folgenden Signaturen konnten nicht ├╝berpr├╝ft werden, weil ihr ├Âffentlicher Schl├╝ssel nicht verf├╝gbar ist: NO_PUBKEY 40E0F448B35AB199 Paketlisten werden gelesen... Fertig Abh├Ąngigkeitsbaum wird aufgebaut. Statusinformationen werden eingelesen.... Fertig Alle Pakete sind aktuell. W: W├Ąhrend der ├ťberpr├╝fung der Signatur trat ein Fehler auf. Das Depot wurde nicht aktualisiert und die vorherigen Indexdateien werden verwendet. GPG-Fehler: https://packages.zorinos.com/stable bionic InRelease: Die folgenden Signaturen konnten nicht ├╝berpr├╝ft werden, weil ihr ├Âffentlicher Schl├╝ssel nicht verf├╝gbar ist: NO_PUBKEY 40E0F448B35AB199 W: W├Ąhrend der ├ťberpr├╝fung der Signatur trat ein Fehler auf. Das Depot wurde nicht aktualisiert und die vorherigen Indexdateien werden verwendet. GPG-Fehler: https://packages.zorinos.com/patches bionic InRelease: Die folgenden Signaturen konnten nicht ├╝berpr├╝ft werden, weil ihr ├Âffentlicher Schl├╝ssel nicht verf├╝gbar ist: NO_PUBKEY 40E0F448B35AB199 W: W├Ąhrend der ├ťberpr├╝fung der Signatur trat ein Fehler auf. Das Depot wurde nicht aktualisiert und die vorherigen Indexdateien werden verwendet. GPG-Fehler: https://packages.zorinos.com/apps bionic InRelease: Die folgenden Signaturen konnten nicht ├╝berpr├╝ft werden, weil ihr ├Âffentlicher Schl├╝ssel nicht verf├╝gbar ist: NO_PUBKEY 40E0F448B35AB199 W: W├Ąhrend der ├ťberpr├╝fung der Signatur trat ein Fehler auf. Das Depot wurde nicht aktualisiert und die vorherigen Indexdateien werden verwendet. GPG-Fehler: https://packages.zorinos.com/drivers bionic InRelease: Die folgenden Signaturen konnten nicht ├╝berpr├╝ft werden, weil ihr ├Âffentlicher Schl├╝ssel nicht verf├╝gbar ist: NO_PUBKEY 40E0F448B35AB199 W: Fehlschlag beim Holen von https://packages.zorinos.com/stable/dists/bionic/InRelease Die folgenden Signaturen konnten nicht ├╝berpr├╝ft werden, weil ihr ├Âffentlicher Schl├╝ssel nicht verf├╝gbar ist: NO_PUBKEY 40E0F448B35AB199 W: Fehlschlag beim Holen von https://packages.zorinos.com/patches/dists/bionic/InRelease Die folgenden Signaturen konnten nicht ├╝berpr├╝ft werden, weil ihr ├Âffentlicher Schl├╝ssel nicht verf├╝gbar ist: NO_PUBKEY 40E0F448B35AB199 W: Fehlschlag beim Holen von https://packages.zorinos.com/apps/dists/bionic/InRelease Die folgenden Signaturen konnten nicht ├╝berpr├╝ft werden, weil ihr ├Âffentlicher Schl├╝ssel nicht verf├╝gbar ist: NO_PUBKEY 40E0F448B35AB199 W: Fehlschlag beim Holen von https://packages.zorinos.com/drivers/dists/bionic/InRelease Die folgenden Signaturen konnten nicht ├╝berpr├╝ft werden, weil ihr ├Âffentlicher Schl├╝ssel nicht verf├╝gbar ist: NO_PUBKEY 40E0F448B35AB199 W: Einige Indexdateien konnten nicht heruntergeladen werden. Sie wurden ignoriert oder alte an ihrer Stelle benutzt.

... I think I should change it back how it was before if I see this amount of errors now.

Yes, you can with

sudo mv /etc/apt/trusted.gpg-bkp /etc/apt/trusted.gpg

I'm sorry, I do not speak German so my brain fried a little trying to follow that. The purpose of the above is to test whether the trusted.gpd file is corrupted- which can cause the updater to fail in the gnome-software store.
If so, you can copy all pubkeys from the above list and add them individually to rebuild the trusted.gpg list. For example:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 40E0F448B35AB199

Next, can you try reinstalling the Software store?

sudo apt install --reinstall gnome-software