Updated Zorin 16 Base, External Monitor No Longer Detected

Hi there -- just started using Zorin OS as my daily driver on a Lenovo ThinkPad X1 Extreme last week and it's really amazing. Kudos to all the hard work that goes into making such an incredibly polished distro.

I've been using my ThinkPad X1 Extreme with an external monitor with no issues, but I just updated the Zorin OS base today, and now it will no longer see the external monitor over HDMI.

I googled around a bit and there are some older solutions involving copying an nvidia.conf file from /usr/share to /etc/X11 but the details didn't quite seem to line up with my situation so I thought I'd ask the collective and see what all I might try.

Output of uname -a for context:
Linux mwoodward-ThinkPad-X1-Extreme 5.11.0-34-generic #36~20.04.1-Ubuntu SMP Fri Aug 27 08:06:32 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Happy to provide additional details to help troubleshoot. Thanks!

Hello and welcome to the forum :slight_smile:

Did you try switching to Nouveau instead of Nvidia driver? It solved my 2nd monitor not detected problem today.

You can also try this solution:


Heya, software update today killed my nvidia drivers.

(base) skrhee@skrhee-corsair:~$ nvidia-smi
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I tried using the additional drivers section under software to get a new driver but no luck. Any advice?

Your post is merged to the pre-existing similar question thread.
Please read my reply above for possible solutions.


working with the 5.11.0-27 kernel worked for me

1 Like

Thanks for the great info! I tried the Nouveau driver, and although it recognized the external monitor, the rendering became unusably sluggish unfortunatley.

I'll give the previous kernel a shot, I'm sure that'll solve it. Thanks for the quick response!

If updating the OS, messes with the Nvidia driver, then the first thing I would do, is re-install my Nvidia drivers.

CTRL - ALT - F2 to enter terminal.

sudo apt-get update sudo apt-get upgrade

sudo add-apt-repository ppa:graphics-drivers/ppa

sudo apt-get update

sudo apt-get install nvidia-driver-470

NOTE, if your notebook is older, basically a machine that is 5-years old, install the Nvidia 430 driver instead. If your computer is much much older, like 10-years old, use the Nvidia 390 driver.

Additionally, if your computer is indeed much newer, like say a computer from 2020, but the 470 driver doesn't work, install the 460 driver instead.

1 Like

Why not install the nvidia driver from the nvidia website ? It worked for me.

@skrhee, did you disable secure boot in the bios ?

nvidia driver was installed already and yes secure boot is disabled

I think your issue is related to this recent bug:

I am currently reverted back to -27 kernel and pinned it till the fix comes.

oh yes we've talked about it earlier in the thread, the kernel change definitely works

1 Like

People on the linux mint forum also report issues with this kernel, weird that i am not affected lol.

1 Like

I think it only affects NVidia users.

4 posts were split to a new topic: Zorin 16 with Intel graphics got blank screen

I am a nvidia user. Gtx 1070 8gb in my acer laptop.

and you are using 5.11.0-34 kernel without any issue?

That is correct, after kernel update i only had to reinstall my nvidia driver from the nvidia site. Running the 5.11.0-34 kernel since it popped up as update.

That is one thing I did not try.

I just rolled back to -27 and decided to wait for next kernel update.

I wonder which one is easier for beginners - roll back to previous kernel or install NVidia driver manually.

1 Like

I am new to linux as well, i managed to do it.

You are very advanced beginner :slight_smile:
I am thinking of someone like my daughter-in-law who almost exclusively uses GUI.