USB Descriptor error in Setup | URGENT!

So, I Was Using Zorin, Then Used Mint, Then Went To Windows 10 And Have Been Using It For A While, And I Was Going To Install The Newer Zorin OS Version. so in the pre boot phase, (after you choose try to install zorin os) when i try, it "loads" but it does not. it also says that my NTFS Is Not Good. So It Says To Shut Down Normally, Witch I Did. And It Still Says The Same Thing. Please Help!

Is the USB formatted in NTFS?
It should not be, if it is.

Are you installing Zorin Alongside of Windows, or installing over Windows and replacing it?

it is formatted as fat32

Since you have Windows 10 installed:
Did you disable "Fast Boot" in Windows - Control Panel - Power settings? You may need to search the net for a detailed guide to it if you cannot find it.

Did you disable "Secure Boot" in the BIOS / EFI settings (motherboard, not the OS) security settings?

i do not have secure boot and i tried to load setup again and it says USB Descriptor Error 1-2 Error -110 oh and if this helps i am pressing left arrow key to see what is going on.

Boot into the Motherboard BIOS / EFI settings and set IOMMU to Enabled

Once done, on the Zorin OS Installer, tap the e key at the grub menu that says "Try or install Zorin"
This should open the grub editor.
Find the line "quiet splash" and add the parameter iommu=soft to it so that it is "quiet splash iommu=soft", then proceed to boot and test...

i am using UEFI by i only have boot options, i tried.

ohhh... This is a Chromebook?

i was able to do it with no windows before, but that was 5-6 months ago.
I Also Have Taken In The EMMC Warning From Others As Well

1 Like

I cannot really vouch for the times where something worked a week ago and does not work today... that is just Computers and Operating systems the world over...
Yes... eMMC can be troublesome on Linux.

sorry, i really want zorin back, is it possible?

It is quite likely possible.
If you want rid of Windows...

I would go about this by wiping the drive of windows and blanking the free space first.
Then format the drive to ext4.
This can be done using a LiveUSB or LiveCD - Zorin OS's Try Zorin can do it, too.

Once that is done, I would then follow the steps to installing Zorin OS on the Chromebook.

thing is, is that i cannot even get to the zorin os interface, it throws that error while booting into try to install zorin mode.

Have you reburned the .iso on the USB stick in case the first attempt was corrupted?

yes, in fact 6 times i did, i even checked the hash! it all matched!

I can only think, at this point, that Windows changed a setting in the BIOS settings.
While Linux OS's will never change a BIOS Setting. Windows can and will. And without any warning or request for permission to do so...

:frowning: aw man

and if you download this iso(Download GParted from and you burn it to a USB, then you create a new part table and format your device, and install zorin like that?
(im ONLY SUGGESTING a solution that for me, having a problem like that, fixed. But I did not use a chromebook)

1 Like

hmmm, i'll give it a shot.

Heya! Sorry, I Was Going Through A Lot Of Stuff In My House And Found My Old Laptop! So I Managed To Get Zorin OS 15.3 Lite (the latest 32-bit edition of zorin) and, I Did My First Dualboot (win7 and zorin), And I Am Very Satisfied With The Results! Now I Am Considering It, Should I Try An Older Version Of Zorin OS? Up To The Greats Now.

1 Like