USB Scandisk adaptor not reading

I have a micro SD card which I use to make videos on my camera. I connect it to my computer using a USB adaptor to save and edit the photos. It was working fine until today when for some reason it is not reading. It appears in the Drives as a "Block Device". I am not able to reformat it, mount it, or do anything. I have tried different port (both 2.0 and 3.0). Sometimes it does not even appear at all. I'm going to buy a new adaptor to see if that works but if not any ideas what could be causing this?

Off the top of my head, it sounds like your microSD card went bad. Micro SD cards have a limited read/write cycle. You could of course try the different card reader to exclude the possibility of a card reader failure.

I am running about a dozen of RaspberryPi here and went through many microSD cards. I had about 5 or 6 cards dead in last 2 years while none of the card readers went bad.

I've tried different cards which is what makes me think it might be the adaptor which is about 5 years old.

Is the microSD card still working ok in the camera?
How is it formatted?

It is working in the camera. I have tested and recorded something new so it must be the adaptor

1 Like

Can confirm now that it was a faulty adaptor. Once I replaced it with a new one worked right away.


Glad to hear that you found a solution.

So the lesson is "never say never" :wink: