Using "Other locations" in the Files browser

Hi all, I am using the Other Locations section of the Files app/browser. I then add an ftp server in the Connect to Server. I login, and can browse the files on the ftp server but it will not download and view the files in most local apps. If I use the text editor it will download and view. However, other apps fail with an error.
Example:

This site can’t be reached

The web page at file:///run/user/1000/gvfs/ftp:host=xxxxxx. com/www/xxxxx.php might be temporarily down or it may have moved permanently to a new web address.

OR

The editor could not be opened due to an unexpected error: Unable to read file /run/user/1000/doc/c0e4426d/xxxxx.php (Unknown FileSystemError)

I've done this before in Ubuntu itself.
Is there something I can check on Zorin setup?

(Zorin Pro 16.3)

If it works on Ubuntu, it will work on Zorin OS.
Have you seen any Permission Denied errors?
Have you double checked your paths and file names?

example:

Interesting that it is noted as a bug. It definite worked well for me before I moved from Ubuntu 23.04 to Zorin Pro. I meant I could scrap my FTP app.

If I check /run/user/1000/doc/ I can see c0e4426d with the directory attribute, plus rwx for me, but I can't change into it! Obviously temp folder but you think I'd be able to go in

I might fire up a Ubuntu 23.04 desktop in a virtual host and try it again

Well that's the quickest I've ever downloaded and installed Ubuntu, twice!

Tried it on Ubuntu 23.04 and it worked. I knew it did but I wanted to be 100%
I then tried Ubuntu 22.04 and it also worked

So I came back to Zorin. I removed VS Code and reinstalled. However, this time I downloaded and installed direct from the source site. It worked. If I download it via the Software App in Zorin it does not work.

I bet you installed the Flatpak version from Software.

2 Likes

:point_up: Yep, I think next time better mention which client you're trying to connect from.

I had no idea. I simply went into the software app and installed it like a normal user would.

I don't blame you, that's what I would've done. It's just that we're seeing an awful lot of issues due to this, as Flatpak is growing in popularity and served as default for many programs.

In any case, the more details you can provide the better for troubleshooting but also for future queries from people on the internet who may be led to this thread.

2 Likes

The reason why the Software Store should have .deb by default instead of Snap and Flat. To many newbies steps on that landmine.

4 Likes

It is only growing in popularity among Certain Developers that want containerized control over the users.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.