V16 Pro Screen tearing/flickering

I installed v16 on a fresh drive, no issues other than my screen is having bad tearing/flickering. Everything I have looked up hasn't worked, my GPU is being recognized and I believe the correct drivers are installed but still having issues.
Any guidance would be greatly appreciated!

uname -a

Linux braden-zorin 5.11.0-27-generic #29~20.04.1-Ubuntu SMP Wed Aug 11 15:58:17 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

lspci -k | grep -EA3 'VGA|Display'

0a:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/390] (rev 80)
Subsystem: Micro-Star International Co., Ltd. [MSI] Hawaii PRO [Radeon R9 290/390]
Kernel driver in use: radeon
Kernel modules: radeon, amdgpu

inxi -Faz

System:
Kernel: 5.11.0-27-generic x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/BOOT/ubuntu_ddpzbg@/vmlinuz-5.11.0-27-generic
root=ZFS=rpool/ROOT/ubuntu_ddpzbg ro quiet splash vt.handoff=1
Desktop: Gnome 3.38.4 wm: gnome-shell dm: GDM3 3.38.2.1
Distro: Zorin OS 16 base: Ubuntu 20.04 LTS Focal
Machine:
Type: Desktop Mobo: ASUSTeK model: PRIME X370-PRO v: Rev X.0x
serial: UEFI [Legacy]: American Megatrends v: 5220
date: 09/12/2019
CPU:
Topology: 8-Core model: AMD Ryzen 7 1800X bits: 64 type: MT MCP arch: Zen
family: 17 (23) model-id: 1 stepping: 1 microcode: 8001138
L2 cache: 4096 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 122951
Speed: 1880 MHz min/max: 2200/3850 MHz boost: disabled Core speeds (MHz):
1: 1879 2: 1845 3: 1848 4: 2171 5: 1824 6: 1874 7: 2101 8: 1884 9: 1882
10: 1888 11: 1883 12: 1882 13: 1884 14: 1909 15: 1882 16: 1877
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Hawaii PRO [Radeon R9 290/390] vendor: Micro-Star MSI
driver: radeon v: kernel bus ID: 0a:00.0 chip ID: 1002:67b1
Display: x11 server: X.Org 1.20.11 driver: radeon compositor: gnome-shell
resolution: 1920x1080~120Hz, 1920x1080~60Hz
OpenGL: renderer: AMD HAWAII (DRM 2.50.0 5.11.0-27-generic LLVM 12.0.0)
v: 4.5 Mesa 21.0.3 direct render: Yes
Audio:
Device-1: AMD Hawaii HDMI Audio [Radeon R9 290/290X / 390/390X]
vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 0a:00.1
chip ID: 1002:aac8
Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus ID: 0c:00.3 chip ID: 1022:1457
Device-3: Blue Microphones Yeti Stereo Microphone type: USB
driver: hid-generic,snd-usb-audio,usbhid bus ID: 3-2:2 chip ID: b58e:9e84
serial:
Device-4: SteelSeries ApS GMMK Pro type: USB
driver: hid-generic,snd-usb-audio,usbhid bus ID: 5-4.1:5
chip ID: 1038:12c4 serial:
Sound Server: ALSA v: k5.11.0-27-generic
Network:
Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
port: e000 bus ID: 08:00.0 chip ID: 8086:1539
IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac:
Drives:
Local Storage: total: 1.36 TiB used: 14.50 GiB (1.0%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 PRO 1TB size: 931.51 GiB
block size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4
serial: rev: 2B2QGXA7 scheme: MBR
ID-2: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
serial: rev: 3B6Q scheme: MBR
RAID:
Device-1: bpool type: zfs status: ONLINE raid: no-raid size: 1.88 GiB
free: 1.70 GiB allocated: 182.0 MiB Components: online: N/A
Device-2: rpool type: zfs status: ONLINE raid: no-raid size: 920.00 GiB
free: 905.00 GiB allocated: 15.40 GiB Components: online: N/A
Partition:
ID-1: / raw size: N/A size: 880.43 GiB used: 4.54 GiB (0.5%) fs: zfs
raid: rpool/ROOT/ubuntu_ddpzbg
ID-2: /boot raw size: N/A size: 1.67 GiB used: 97.4 MiB (5.7%) fs: zfs
raid: bpool/BOOT/ubuntu_ddpzbg
ID-3: /var/log raw size: N/A size: 875.90 GiB used: 7.2 MiB (0.0%) fs: zfs
raid: rpool/ROOT/ubuntu_ddpzbg/var/log
ID-4: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap
swappiness: 60 (default) cache pressure: 100 (default) dev: /dev/nvme0n1p5
Sensors:
System Temperatures: cpu: 39.8 C mobo: N/A gpu: radeon temp: 59 C
Fan Speeds (RPM): N/A
Info:
Processes: 599 Uptime: N/A Memory: 31.36 GiB used: 2.69 GiB (8.6%)
Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash
v: 5.0.17 running in: gnome-terminal inxi: 3.0.38

Also feel I should mention that every once in a while everything freezes, apart from the mouse cursor, and I am forced to restart my machine.
TearFree_On

Hi,

Try see if there's a newer driver for your card in this PPA help;

sudo add-apt-repository ppa:ubuntu-x-swat/updates
sudo apt update && sudo apt -y upgrade
2 Likes

Doesn't seem to have solved the tearing. (0 updates 0 upgrades)

The card that I have is not new by any means btw, R9 390, if that makes a difference.

I do not have that hardware, but searching Ubuntu 21.04 with your card model gave me this solution... it may work for you:

In a nutshell it said to install dpm-query. Please let us know if it works for you.

1 Like

I still haven't got it to work, and I'd love to try that solution but I haven't been able to install dpm-query:
/bin/sh: 0: Can't open /usr/bin/dpm-query
The AMD forum was no use, can't access whatever tutorial is linked.
I don't understand why I keep getting this error.

Can you please open a terminal and paste in:

git clone https://github.com/JuBan1/radeon-dpm-control.git
cd radeon-dpm-control

cd radeon-dpm-control

./configure

make install

Once done, hit alt+F2 and enter into it just the letter r and hit the enter key - this restarts the Gnome Shell.
Then test your Radeon Balance?

1 Like

Can you expand on what you mean by "test your Radeon Balance?".
I don't know what you mean by that. Also, I did install that when trying to get dpm-query to work, however, the Github page mentioned Enable the extension in your Tweak Tool., I'm not sure what that is

sudo apt install gnome-tweaks

This will install gnome-tweak tool. You can find it in the app menu by opening the app menu and typing "tweaks" and it will show right up.
Once opened, in the Left Pane, you should see "Extensions". Click that, then look in the Right Pane of the window and scroll down to find dpm-query.

I mean only test your graphics for tearing and flickering, sorry.

1 Like

Thank you so much! This has done it for me.

For anybody else having this issue, here's what I did:
Installed AMD Mesa drivers, rather than AMDGPU PRO (which came installed, and not sure if this had any effect).
Installed dpm-query, then installed radeon-dpm-control, which is an extension for dpm-query.
Finally, installed gnome-tweaks to enable radeon-dpm-control.

There are a few other things I attempted that could have had an effect, such as setting TearFree from auto to on, and adding command-line arguments to GRUB as suggested on Reddit. However, I would be very cautious changing the default GRUB arguments, can cause black screening and probably other booting issues. I had to go into Zorin advanced recovery mode and change the arguments in root.

Thanks to Aravisian and 337harvey for your help.

Edit: I am still noticing some minimal screen tearing. Mostly at certain specific moments like at the password popup. I'm not trying very hard to find a solution for this though because I am mostly using Linux for my computer science classes and programming and dual booting windows on another drive for most other things like gaming. If you know of a more complete solution I would still very much appreciate it.

3 Likes

Thanks for sharing the full walk-through.
I think Mesa is an important step and thanks to 337harvey for supplying the dpm-query suggestion.

2 Likes