"Weather information is currently unavailable"

Newbie here!
What a great experience has Zorin OS been so far! By far the slickest distro I have ever used. Thanks for the hard effort.
Now to the issue: I would like to make the weather app work properly. For now it can not show any forecast and for most of the locations it wouldn't even find a real-time weather report. And in the panel it would only show the message: "Weather information is currently unavailable"
I saw that GNOME weather uses libgweather and it is already up-to-date (3.28) for Ubuntu 18.04.
There have been upgrades of libgweather (3.36) for Ubuntu 20.04 though, but I guess they are useless for Zorin OS 15.3?
Do you guys have any tips on how to make it work? I could probably try to use other weather apps, but they wouldn't be integrated as seemlessly as the default one. And they all seem to have their own little bugs anyway...

1 Like

I dont have any issues with the default Weather app. Working fine, no issues.
Automatic and manually added location. From panels also.

Maybe try reinstall app ..

oh btw, I am on beta 16 Zorin :slight_smile:

1 Like

Can you try installing the Bionic up to date libgweather:
http://archive.ubuntu.com/ubuntu/pool/main/libg/libgweather/libgweather-3-15_3.28.1-1_amd64.deb

Reboot after install or configuration and test.

1 Like

Thanks guys, I did install the Bionic update manually. And nothing changed. It seems that the proper fix is from a more recent version, which is only compatible to Fossa. So maybe that's why it worked for you on Zorin 16 beta...

1 Like

It really should work with the Bionic update.

Looking at the Bug reports, it seems a commonly filed bug:

Across Distros:

Some blame NOAA, Others say it is a Gnome Shell bug.... Figures...
https://bugzilla.redhat.com/show_bug.cgi?id=1393700

1 Like

Oh, so you think I could install libgweather-3.36.0 / gnome-weather-3.36.1 although it doesn't seem to be supported by Bionic? Will give it a try and report back!

I tried sudo apt-get install libgweather-common_3.36.0-1_all.deb with the result of
E: Unable to locate package libgweather-common_3.36.0-1_all.deb E: Couldn't find any package by glob 'libgweather-common_3.36.0-1_all.deb' E: Couldn't find any package by regex 'libgweather-common_3.36.0-1_all.deb'
I guess I got the error message, because I am running Ubuntu 18.04 and not 20.04, is that correct?

I was referencing bug reports showing that Gnome-Weather, as an application, seems to be afflicted with this bug regularly. Not to suggest one version over another, but rather that users of Gnome Weather seem to experience outages on occasion.

The APT install you entered into terminal would need to have a valid location to find the .deb file you referenced.
I do not have any reason to believe that the focal package would work on Bionic.
That said: You can find the Bionic .deb package here:
http://archive.ubuntu.com/ubuntu/pool/main/libg/libgweather/libgweather-common_3.28.1-1_all.deb

and the Focal package, here:
http://archive.ubuntu.com/ubuntu/pool/main/libg/libgweather/libgweather-common_3.36.0-1_all.deb
What have you to lose?

I also have this problem that the weather app does not show the forecast. I tried it on Zorin 16 beta as well, but the issue persists.

1 Like

Thanks for pointing me directly to the packages. No luck with installing either of them though. The problem remains that I can't get any data for my city and no forecasts for all the other cities I tried.

Installing the 40.0 version seems to fix the issue. You can download it from here
Flatpak is not required for the installation. It shows the forecast now, but the UI does not match the system UI.

1 Like

@taha_mcp It is normal that Snap and Flatpak installs do not follow the gtk theme. I believe flatpak can be made to do so and Zorin OS Themes are also included in Flatpak.

@timothys_monster; this may sound goofy... but have you tried changing your location to some distant far off land, then changing it back?

2 Likes

@taha_mcp That sounds very promising! Unfortunately, I don't know how to install it without Flatpack... Would you mind giving me a hint on how to do that? Thank you!

@Aravisian Yes, I actually did try it. I am in Europe and tried switching to New York and back again. Nothing changed :frowning:

Oh yeah it's actually very simple. Download the package from their website (Direct link) and open it by double clicking it. Eventually a window should pop up with the option to install. When trying to install, an error pops up that Flatpak was not found. Ignore it and continue with the installation. After it fully is installed it should give another error but ignore it. The app works :)) Restart your computer and you should see the Weather app in your applications list. You can search for it in the mainmenu/startmenu.

2 Likes

@taha_mcp Thank you very much! Finally a weather app that is working :smiley: And it was dead easy to install as well. Great!

2 Likes