Webcam not detected, dmesg | grep returns nothing

Hi, new to Zorin (and Linux in general) :slight_smile:

I tried Cheese and it said "Device not found". Did some google search and tried "dmesg | grep video" and "dmesg | grep camera" but both returned nothing.

What are the proper steps I should try to get the built-in webcam detected? Thanks.

CTL ALT F2, to enter Terminal. Type in the code bellow...

sudo apt-get install v4l-utils

Now type in this code to list devices connection...

v4l2-ctl --list-devices

Please post the output of the last command in here. We first have to see if your system detects your camera.

The command gave out error:
Failed to open /dev/video0: No such file or directory

This means that your system does not detect your webcam. This could be due to the kernal version. What computer do you have, how old is it?

My laptop is an Asus T100TA released in 2015 (Atom Z3740, 2GB RAM).

I didn't know that this was a tablet that we were dealing with until you mentioned it. Found your tablet here.

I have never ran a linux OS on a tablet before, so I have 0 experience. I believe @Aravisian does have experience running a Linux OS on a tablet.

At least we have some info now on the system you are trying to work with. Seems your tablet came with Windows 8.1 originally.

EDIT: I found that other's have run into the same issue that you have. It seems there are no Linux drivers available to support the Intel AVStream Camera. Seems Intel created it souly for Windows, sad.

Yes, it's a 2-in-1 tablet/laptop. Don't know if it's really that special. With its keyboard dock, it basically works as a laptop.

It's not Intel, but I'm quite sure it's Aptina. However, in Windows, if a device doesn't have driver, Windows still sees it and lists it as "Unknown Device" - is there something similar in Linux/Zorin? I feel that the device is not even "seen"/detected by the OS?!

If somebody isn't able to help you to get the Zorin OS to see your built in webcam, you might have to go another rout. I assume your tablet has a standard USB A port?

Logitech 720P Webcam

According to the page, it supports UVS, which Linux has drivers for. Which means, that webcam should be able to interface with Linux, provided yoru tablet has a USB A standard port on it that is.

Thanks for the suggestion. Alright, I'm not in a rush for webcam support, I'll wait some time for some other input (it's also a way to learn how to config things in Linux, I guess).

I have an hp laptop and could not get webcam to work. I found in the owners manual that by pressing fn+Esc while booting up that the camera started working. I had to adjust resolution to 640 x 400. That’s it, that function seemed to turn on the camera in cheese. I am running Linux mint


A post was split to a new topic: Webcam not detected