WebGL and Intel 945GM Express

I tried to look at UK Covid map (https://coronavirus.data.gov.uk) on my Zorin rig yesterday, using (latest) Firefox 64bit browser. After a bit, received message stating WebGL is needed.
From reading a number of posts on different websites, I am still unclear whether my graphics hardware is capable of WebGL, or if it is a graphics driver issue. Software updater shows no additional drivers are available for my machine.
Graphics: Mobile Intel 945GM Express Chipset Family
NB: I booted same machine into Windows and got same result from browser.

Any ideas anyone?

I’m not sure if these are relevant but they’re all I could find:

  1. Some talk of the vesa vs Intel driver here. Vesa can be found using Synaptic.

  2. https://01.org/linuxgraphics/forum/update-tool-support-forum/intel-mobile-945gm/gms-943/940gml-express-wont-play-hd-videos-it

@carmar I have already seen the first of these. The second one, after reading, I dont think is going to help.
It is not just a linux problem as it is same under Windows.
I was just hoping maybe there was a driver or other software update that could do the trick. If not I will put it down to age of the hardware and WebGL not being nice and backwards compatible for older kit.

How about https://www.binarytides.com/enable-webgl-firefox-ubuntu/ ?
There is also the option to see if chrome behaves for you https://techwiser.com/enable-webgl-chrome/ and https://askubuntu.com/questions/299345/how-to-enable-webgl-in-chrome-on-ubuntu

@carmar. Thanks for the research, it is much appreciated.
I have no desire to use Chrome, so will concentrate on any fixes that are for FF.
I will report back if any progress.