Why are the Buttons in some Software so big?


I have big problems with Buttons in Software (Literally). These Buttons are compared to the rest of the Screen way too large. (I have discovered this problems in Gimp, VLC, etc. )

I use dual Screens, which caused some other problems which I managed to solve but I do not know how to solve that this weird problem.

Can someone help?
Thanks : )

What icon set are you currently using?

@DasMedium What flavour of Zorin are you running?
For Zorin Core (Gnome Desktop) you can adjust desktop icon size. See my old post here: Modifying Desktop Icons - #6 by zabadabadoo

IMO, the minimum size of icon’s is still big, cf Windows icons, when viewed on a small laptop/notebook screen.

Currently I am using the Zorin-95 Icons

I am using the Education Version of Zorin.
But my main problem aren’t the Icons on the Desktop but instead the enormous Buttons in VLC and other programs. These giant buttons are making the programs unusable.

Use Synaptic to reinstall VLC (or terminal if you prefer).
If your current VLC is a snap, remove it using sudo snap remove vlc and install it using sudo apt install vlc (or Synaptic).

Unfortunately, that did not work. The Buttons are still way to big

In VLC, make sure that Tools → Customize Interface → Big buttons is unchecked.

It is. And this Problem isn’t just accruing in VLC but also in GIMP, LMMS (a Music Software) etc.

Can you please post screenshots of GIMP and LMMS icons as you see them?

Also, though I can think of no plausible way that this could have changed without your knowledge, can you double check the index?
Navigate to /usr/share/icons/Zorin/index.theme and open it with a text editor.
Scroll down a Short Ways to here:


And ensure that your minsize is 16 and not 64.

I checked, it’s set as it should.

Pictures of the other programs:

Gimp isn’t even fitting and I can’t shrink the window

LMMS picture is following in a separate post because I can’t post more than one picture

LMMS is the worst of all. I can’t use it properly

This is a first.

It looks like only the Scalable Symbolic icons are affected.
And I can see no way the icon theme itself is the cause (though I had you check one aspect of it, anyway).

Gimp window- click “windows” on the Menubar, uncheck Single Window Mode- and test if that alleviates the inability to resize the window.

That makes at least gimp kind of usable, but the Toolbar still isn’t fitting on my screen.

In the past I had some problems that were caused by my dual Display arrangement. Maybe the big Buttons have something to do with this as well.
I have done some testing in the past and if I move e.g. LMMS to my second screen the buttons are getting kind of normal-ish but everything else like Menus and Text is getting unbelievable tiny (like 5 or 6 Pixels maybe) and impossible to read.

Do you have HiDPI enabled?

What is HiDPI?
Never heard of it

Gimp seems to have a setting: Guess icon size based on screen resolution.
Can you try changing that to a different custom size by going to Edit on the menubar, then preferences, icon theme.
Gimp and VLC are both QT based apps. I wonder also if you are experiencing oversized symbolic icons on all QT based apps, in combination with your Screen resolution.
Possible testing methods include- changing screen resolution to something else; like 1440x900 and then testing.
In Gimp, you can also use a non-symbolic icon set to see if that sizes properly.

I tried everything but nothing really worked.
I googled and it turns out that LMMS also is an QT based app, so i tried other apps like LibreCad and Scribus (because they were pre-installed) but those looked fine. (I have compared the button-size them with screenshots from the web)

So, it appears to be an issue where a few different factors all weigh in at once - QT based apps on High Resolution Display.

I think our clue and direction to follow is in




Experimentation may be needed. May need to try different numerical values following the = sign, for example, “QT_SCREEN_SCALE_FACTOR=0.5” or if using multiple screens, “QT_SCREEN_SCALE_FACTOR=0.5;0.5”. Maybe “=1.5”.
This can be exported from home by including it in
Or placed in the apps exec path.
I am finding this bug listed for Gnome Desktop, but strangely, not for XFCE4. I am not sure if this means that the bug is only present on Gnome or if it has just not been reported as much on other Desktop Environments.