Why doesn't the program appear in Z menu pop up?

The program I was looking for did not appear when I clicked the menu pop up (bottom far left of screen under Z logo, not sure what you call it). I had to find it thru activities search instead.

To add/delete items from Zorin menu:
Core: Zorin menu -> Main menu OR alacarte
Lite: Zorin menu -> Menu editor OR menulibre

I clicked the Zorin logo bottom left corner and typed "main menu" and "alacrate" and got no results.

alacarte (Core) and menulibre (Lite) are meant for the terminal.

Quite a while ago I had installed a programme that did not appear in the "Start menu" (which is what I call that main menu). I opened 'Software' on the right of the menu, clicked on Q on RH side to open a search bar, then entered the name of the programme. Eventually it showed the programme as installed. After restarting my PC, the item now appeared in the Start Menu. This might work for you.

I can attest to this, sometimes after installing software on Linux, it requires a reboot, for the app to show in the applications menu.

You can try typing the name of the App in
Start Menu>Type to search
and see if it comes up.

He said he tried it and it didn't work.

1 Like

It does show up in Type search, but I would like to show up when I click that Z menu icon lower left of screen

I checked software but I didn't see it under 'installed', restarted no avail.

Most applications are told during nstallation process to create a .desktop entry and be added to the app menu. But not all software you install include this in the installation. This is more true when building from source.
To add a program to the app menu, create a .desktop file in your ~/.local/share/applications directory.

Just create a new document, then name it by that application name .desktop. As an example, if I was making one for gimp, it would be gimp.desktop.
Within that document, paste in this template:

[Desktop Entry]
Name=Application Name

Replace the "Full/path/to..." sections with the full path to the icon and the program executable.
You can reference finding the Application Name where you asked, here:

Should I use terminal only to create this?

However you want to. That is the beauty of it is that you often have many different methods available to achieve a purpose. You can create a new file in whatever manner you feel most comfortable with. If you are a visual person, then using your file manager to navigate to the ~/.local/share/applications directory, then right clicking and choose "create new document" may be the way to go.
Or you can use the terminal.

Necroing this thread since I had the same question and want to add some additional clarity to the process for myself and future users..

Is there a way to navigate to an address like this one by entering the path into the file explorer (like you can in Windows?)

As a (somewhat) new Linux enthusiast, I can't find it manually after a few minutes of digging, and found it odd that there's no clear way to paste the path into the location at the top.

I was able to paste it into Terminal, but this then forces me to create and add the file without the GUI as I equally can't choose anything from the Terminal window to "open in explorer" (while I can choose to open a location in terminal from explorer

You can. The dot infront of ~/.local means it's hidden. All files with a dot infront will be or are hidden. So to see the hidden files go to Nautilus menu and choosee "Show Hidden Files".

Faster: Use the search button in Nautilus to get quick access.

1 Like

Thanks - perhaps I am not fully understanding; I've enabled hidden files, clicked search, pasted in "~/.local/share/applications" and nothing is returned.. I've backed off all the way to "~" and I still get no results. (happy to start a new thread for this, new to the community and don't want to add unrelated ■■■■ to the end of the thead if that's frowned upon.

Thanks for your patience - I've not seemingly had an issue figuring out how to navigate places in other distros, not sure what I am doing wrong or why I am not getting it this week

The ~/.local directory is in Zorin OS by default.
You are saying that in your home directory, you are not seeing the .local folder with Hidden files shown (ctrl+h)?