Why is it so hard to make an custom or cloned .desktop file on my desktop

So I have a problem, so I installed Steam [Flatpak because of ProtonGE] via Software Manager. If I want to play a game, I would have to open Steam and click "Play" on the game I want to play. So i opened steam to right-clicked my game and clicked on "Add to Desktop" so later i found out it goes to the directory <~/.var/app/com.valvesoftware.Steam/Desktop> and so I moved the files over to my actual desktop folder and when i double click on it it opens TextEditor and then i did some research online and made a working bash (.sh) file but if i want it on my desktop obviously want it to look the part so i want to give it an icon and the only way i can do that according to the online forums i have been reading is make an .desktop file. I spent a whole day on this and followed alot of online tutorials on how to make a .desktop file or even link the file and bash file and trying putting my file in <~/.local/share/applications> route and i tryied things like adding steam to my desktop and edit that to open the game (and it works) but i cant have more than 1 "Steam.desktop" on my desktop.

I am not sure if there is another way to get this working besides with a .desktop file or if i am just not getting it right still after spending 8 hours (about a full day work) on the problem any help will be appreciated thank you in advanced.

ProtonGE works with the .deb package. It could give you less headache than fighting with flatpak.

but i cant have more than 1 "Steam.desktop" on my desktop.

Then give it another name then :wink:

The easiest way is to copy existing steam .desktop file from ~/.local/share/applications and alter the steam number and title ofcause.


i dont know how to install GE without flatpak =/ also its specifically becuase of steam.desktop i did make copies and rename them but it always opens TextEditor

would you mind helping with GE part becuase the GitHub page instructions isnt easy for me to understand at this moment

This is a little old, but should work. If you need another version of GE just change the numbers:

I did what you said it; also while I was doing what you asked I made a discovery online too and would like to know what you think about this app.

I installed it, and it seems to work fine too as I got the latest version of GE this way (I would still like to hear what you have to say about the app) ANYWAYS when I click create desktop shortcut in steam it shows up on my desktop now, but it just opens it in TextEditor still. I made sure it is marked to run as an executable program in the "properties" section and I ran "chmod +x Phasmophobia.desktop" in terminal too; also the information in the Phasmophobia.desktop file game is correct.

So I checked my Zorin Menu for the game, and it is there, so I tried to execute it from the Zorin Menu, so it works thatway. I deleted the file from my desktop and re-added it through the Zorin Menu and re-tried the execution, it seems to work that way.

Thanks for your help to get my games on desktop to work BUT it still leaves the question of why can't I create a custom .desktop file I do not know if I am doing anything wrong and wouldn't mind a tutorial either as I like to make small scripts too

1 Like

I think there are better ways to create the desktop shortcut without an extension...
However, I find this gnome extension very useful:
You will need gnome tweaks for this..

sudo apt install gnome-tweak-tool

After installing and enabling, just right click on the game in the Zorin menu and click on "Add to Desktop".


Is this what you mean?

1 Like

Yes, that's what I am talking about...

1 Like

its already a thing and it doesnt help much becuase i still have to make custom files for my Camera System and "RDP's" and it will only allow 1 app of each app on the desktop thro the zorin menu and when i make my own custom .desktop file all that custom file does is open in TextEditor instead of execute

Without the extension? Interesting...It was not there when I needed it. I guess it was added later..

1 Like

Still the question Lies even when my apps like steam make .desktop files for the games or if i make one then it still just opens in TextEditor instead of starting/executing

Can you please right click on the desktop icon and send the screenshot of the "properties" of the file?

sure here you go and please note i did try the "reset" button alot of times

Seems OK to me..
When you right click on the icon...do you get an option to "Allow launching"? If so please allow it..

Yeah click on "allow launching".

1 Like

oh i missed it lol
it works thanks

1 Like

Oh well...there you go.
At first I also created shortcuts manually by creating a .desktop file then marking at executable and finally allowing it to launch.
Later I downloaded the extension that I mentioned above and it worked like a charm..
The first way worked for you, which is the proper way. Glad I could help.

1 Like

I don't know what happening but one game what i played working worse. Freezing or something not smoothly. Something changed on Steam or somewhere. I have some freezeing like movie play and pause repeatly.

Perhaps graphics card or drivers for graphics.