Wi-fi and right click not working

Recently I brought Zorin Ultimate and I have been experiencing issues with the right click function and Wi-fi. Help would be greatly appreciated.

Device: Honer Magicbook 15

Can you elaborate a bit more on the specific issues? Also, can you provide the output of lspci ?
Regarding the right-click mouse function, I suspect it may be hardware failure given that it is only affecting right-click. You can try playing around with the settings on Settings -> Devices -> Mouse & Touchpad but I’m not sure if toggling the settings there would make any difference.

Wi-Fi issue: Here’s the output (I can’t right click to copy/paste)


Right-Click issue: I tried toggling it in the settings but it didn’t fix the right-click issue.

Thanks. Sorry but I should have asked this one instead: sudo lshw -c network
Could you please provide that one?

You can select all output in the terminal and copy using the Edit button on the terminal menu.

On the right-click issue, try this: https://itsfoss.com/fix-right-click-touchpad-ubuntu/

1 Like

*-network DISABLED
description: Wireless interface
product: Realtek Semiconductor Co., Ltd.
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlp2s0
version: 00
serial: 8c:c8:4b:e9:c2:5f
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rtw_pci driverversion=5.4.0-60-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
resources: irq:68 ioport:2000(size=256) memory:c0600000-c060ffff
*-network
description: Wireless interface
physical id: 2
bus info: usb@1:3
logical name: wlxe8de27a1d4f3
serial: e8:de:27:a1:d4:f3
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=rt2800usb driverversion=5.4.0-60-generic firmware=0.36 ip=192.168.1.8 link=yes multicast=yes wireless=IEEE 802.11
right click issue: Thanks that solved the issue :slight_smile:
P.S I am using usb because the pci dose not work.

What happens if you run

modprobe -rfv rt2800usb

modprobe -v rt2800usb

In terminal, then reboot and check connection?

Thanks for trying but the usb wasn’t the issue… I did try though but it did nothing
Screenshot from 2021-01-11 17-52-30

Try sudo ifconfig wlan0 up

Thanks for trying but…
wlan0: ERROR while getting interface flags: No such device

sudo ifconfig wlp2s0 up

Try that?

If Aravisian’s suggestion doesn’t work, try: rfkill unblock all

Oops on not giving the correct logical name but Aravisian caught that.

1 Like

For aravisian’s it gave this error:
SIOCSIFFLAGS: Invalid argument
And for carmar’s there was no text.

Have you tried using a hammer on the computer to fix it real good?
Sigh… That error usually means that he kernel is not assigning the mac address to the device. I cannot remember off the top of my head a fix, but looking it up… Will edit in a moment.

Do you know how do I fix it?

Apparently, I do not…
As I remember, the settings were stored in /etc/conf.d or /etc/init.d/net but… I am not finding any of those files on my copy of Zorin.

Trying to search the web but not yielding much. One thing I am seeing on a couple forums is users suggesting that changing out their realtek driver solved the problem.
This is not something I can test handily…

Yeah, that dose not work…

What kernel are you running?

uname -a

Did you replace the Rt driver with rtl8812au-dkms?

Here:
Linux laptop 5.4.0-60-generic #67~18.04.1-Ubuntu SMP Tue Jan 5 22:01:05 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

On the kernel- you may actually try Downgrading the Kernel to an earlier version. I realize the idea of downgrading a kernel sounds a bit odd, but please bear in mind that the earlier kernel versions worked fine before the latest and greatest came out… The Latest Kernels are really more about meeting the needs of people using the Newest and latest computers which does not really apply to most users, anyway.
But the earlier kernel is more likely to support the wifi realtek drivers.

That said, you may prefer trying to replace the driver with rtl8812, first.


I have tested that first and checked that the github page and the clone work.

I had to fix a wifi problem on fedora to enable a TP-Link dongle.

With the use of dkms dynamic kernel module support I was able to install the aircrack-ng driver to support the hardware.