Wifi adapter not found after full-upgrade Z16 pro

I just did sudo apt update && sudo apt full-upgrade, now my wifi adapter can't be found. I'm tethered to my phone atm.

I've been through the other posts here, but nothing has worked. I also tried this solution, but that didn't help either. 20.04 - Killer WiFi 6 AX1650 in Ubuntu Doesn't work at Gigabit - Ask Ubuntu

When I look in Additional Drivers only my Nvidia is listed.

I use this computer for work and need to fix this asap. Super appreciate any help!!

It sounds like you removed some previous installed packages with this apt full-upgrade command. I never run this command myself. I usually stick to apt upgrade or apt dist-upgrade

while “apt full-upgrade” command is used to do the same thing except if needed previously installed packages are removed to make the upgrade happen.

Did you install a driver for this WiFi adapter manually?
If so, I am afraid you need to repeat that procedure one more time.

Or perhaps the previous Wifi driver needed DKMS.
@Tink as an experiment, can you boot into the Previous Kernel and test your WIFI?

1 Like

Thanks for the reply @FrenchPress . I had no idea there was a difference or that I shouldn't be using "full-upgrade". Wifi was working when I first installed, so I haven't a clue how to install it now.

1 Like

Or perhaps the previous Wifi driver needed DKMS.
@Tink as an experiment, can you boot into the Previous Kernel and test your WIFI?

I don't know what DKMS is or why it would suddenly be missing.

Sorry to be a pain, but how do I boot into a previous kernel?

I also learnt such things in past hard way.
I am still traumatised from DD command which went wrong :scream_cat:
Linux commands could be very powerful.
Use it with utmost caution :wink:

Yeeeaaaah... way too many "painful lessons" with linux. It's thoroughly kicked my butt.

1 Like

I think you need to press SHIFT key while booting to get grub menu.

You may need to experiment based on what build you have.
Hold the left shift key or tap it vigorously to see the Gub Menu with Advanced Options for Zorin
If that just does not work, try tapping the esc key instead of left shift key.
Once you see Advanced Options for Zorin, arrow key to it and hit enter. Now, error key down to the kernel version 5.11.0-38 or any prior to -40. Hit enter.

DKMS helps to assign the Wifi (Or graphical or other driver) to the Modules in the kernel if the kernel changes. Without DKMS, a change in the kernel can cause the driver to not be read or not be read properly.
Most drivers do not need DKMS, but some wifi manufacturers have no respect for Linux at all and code only for Windows.

2 Likes

Shift key when hes using (legacy) bios
Escape key for efi/uefi

2 Likes

That's right!
I forgot that one :sweat_smile:

1 Like

I have a dual boot, so that was no problem. However, whenever I tried to log in through the advanced options from any other kernel version, it went straight to the ttyl screen. After 4 tries I gave up. Gah!!

Thanks for explaining DKMS. Dell is pretty linux friendly. They even offer "off the shelf" computers with linux installed. I have no idea what caused this issue.

The only way I was able to fix it was by restoring my backup from yesterday. So frustrating, but at least it's working again. SO APPRECIATE your help guys!! :revolving_hearts:

4 Likes