Wifi disconnecting problem

this problem keeps irritating me.When i am downloading something or doing important stuffs,wifi keeps disconnecting can anybody solve my problem.

Can you please post the output for

sudo lshw -C network

You may need to disable Powersave for wifi

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Change the value to 2

wifi.powersave = 2

Tap ctrl+o to overwrite, then the enter key to save current configuration, then tap ctrl+x to exit the editor.

i have set powersave value 2 before itself but problem is not solved :smiling_face_with_tear:

1 Like

I see that you are on the 8821ce driver... You might check for error logs:

dmesg | grep 8821ce

journalctl -xe | grep 8821ce

Interesting... The module taints the kernel - it appears unsigned.

In your BIOS Settings, is Secure Boot disabled?

How did you install the 8821CE Driver? Is it installed with DKMS?
Was the wifi cutting out on an earlier kernel before the system upgrades brought the -88 kernel?

I really don't understand what your saying bro please solve my problem :sob:

You can access your BIOS settings at Boot Up. Which key does it depends on manufacturer is and usually it is displayed on the screen at boot. F10 or F2 or F12 are common ones.

Did you install the driver yourself or is it using one that came with the Zorin OS Install?

DKMS is Dynamic Kernel Module Support. If you had used it, you would likely remember it. :wink:

Is this a new problem that started or has it been doing this from when you first installed Zorin OS? Did you install Zorin OS recently?

I wish I was able to reach out and just solve problems, but I cannot. Solving problems is always a team effort where we must all work together.
The user asking must put in the effort too, since only they have access to their computer, remember the details of what they have done on it or installed to it and so on.

yaa secure boot is disabled.I think i have not installed any drivers when i installed zorin OS.idk what is DKMS is.Yes WiFi is been cutting out from beginning itself when i installed zorin OS and actually i installed zorin OS recently like its been 2 to 3 months i guess.And there is also Bluetooth problem it doesn't connect to my devices.

Ok, let's try installing your driver and see if that helps.
If you are able, connect using Ethernet or using your Mobile Hotspot (phone) tethered with USB cord.

The only source I can readily find is this one:

It's worth trying. The easiest way is using terminal, so just copy and paste and follow the steps.
Ensure that the necessary packages are installed including DKMS

sudo apt install git build-essential dkms

Using GIT, grab the driver from the github source

git clone https://github.com/tomaspinho/rtl8821ce

This will save it to your Home Folder, so using the Change Directory command cd, you do not need to follow a path. Just cd directly into the downloaded folder:

cd rtl8821ce

Give the installer and the remover (in case you want to remove it if it doesn't work) exec permissions:

chmod +x dkms-install.sh

chmod +x dkms-remove.sh

Install the driver (which will utilize DKMS. DKMS is Dynamic Kernel Module Support and it allows the driver to be tied to the Newer Kernels that you upgrade to without having to reinstall the driver every time that the kernel upgrades)

sudo ./dkms-install.sh

Once done, reboot and test Wifi and Bluetooth.

punith@punith-HP-Laptop-15s-eq2xxx:~$ cd rtl8821ce
bash: cd: rtl8821ce: No such file or directory

I just tested running git clone https://github.com/tomaspinho/rtl8821ce and then checking that the rtl8821ce folder was placed. It was.
At that point, running

cd rtl8821ce

worked. Please check that you ran the Git Clone Command above and that the folder was placed in your home directory.

In your screenshot, you see a Fatal Error.

Reconnect your net; disable any VPN or Proxy settings or check your connection.

everything is disabled.

This message is unclear. What do you mean by everything? I can see your Network was connected because the previous installations went through (git, build-essential and dkms installed via the net).
Do you use a VPN? Do you use a Proxy?
git config --global --unset http.proxy

means VPN is disabled and i don't use proxy and from few minute my wifi is working without disconnecting.

Which VPN do you use? VPN's can be tricky little beasts.

I can only suggest that you run the proxy disable command I posted above in case the VPN you are using is enabling a proxy for you.
And recheck your connection and ensure you can successfully connect when you grab the package.
You can sidestep using the terminal by navigating directly to the GitHub page and clicking the Green Clone button. This will save to your Downloads directory.
So you will need to add that path to your cd command:

cd ~/Downloads/rtl8821ce