WiFi Not Found after Suspend, Sleep

Yesterday I’ve installed Zorin Os 15.3 Core on my laptop and I find it great overall.

Unfortunately, every time my laptop wakes from sleep mode, Suspend, Stand-by (or I turn the WiFi off), the WiFi connection doesn’t work, the icon disappears from the bottom bar and the network manager shows " No WiFi adapter found" even though it works perfectly after I turn on or reboot my device.

How can I fix this annoying bug?


Can you try this to see if it works for you? https://www.scivision.dev/ubuntu-no-wifi-on-resume-from-suspend/

1 Like

I’ve just tried but it didn’t work! :frowning:

Please provide the output of lshw -c network

Also, try the answer here, https://askubuntu.com/questions/762198/16-04-lts-wifi-connection-issues-with-realtek-rtl8723be-adapter with your wireless card info from lshw

Now it’s even more unstable…

This is the output:

       description: Wireless interface
       product: Illegal Vendor ID
       vendor: Illegal Vendor ID
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: wlp1s0
       version: ff
       serial: 24:41:8c:b1:67:8c
       width: 32 bits
       clock: 66MHz
       capabilities: bus_master vga_palette cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.4.0-64-generic firmware=29.1044073957.0 ip= latency=255 link=yes maxlatency=255 mingnt=255 multicast=yes wireless=IEEE 802.11
       resources: irq:128 memory:80100000-80101fff

Btw the laptop is a Chinese Teclast F7 plus (bought on Banggood…)

thanks @carmar for your help!

What was the output the first time you ran lshw -c network?

Also, you can perform a fast test by running your installation media as “Try Zorin” without installing, then suspend the Trial Zorin
user: zorin
Password: -blank- There is nothing to type for the trial Zorin password

Resume from suspend in the Trial Zorin and check net connection. If it works, then your currently installed Drivers are the issue.

1 Like

Hello Andrea, interesting you should raise this.
I have the same issue on my laptop.
Yet it runs from the exact same OS copy saved to a flash disk as my 2 other DT’s which never have any issues.
It has always puzzled me.

I tried @Aravisian’s suggestion of trying with “test Zorin” and it would seem in my case at least, the drivers on the laptop are guilty. I can live with that for now, the machine is an old, ex early Win 7 model anyway.

Just out of curiosity, how did you get on?

1 Like

I’m sry I Haven’t been able to answer, I’ve been very busy.

This is the output when the wifi is working (only 2-3 minutes or less after rebooting)

I tried what you recommended when running Try Zorin on my installation media USB Drive, and after suspend Wifi still disappears from Settings

Can you list the exact steps you did (including commands) when following the answer listed in the first link I gave you?

Can you run in terminal

rfkill list

and see if anything is flagged?

After resuming the computer from suspend, could you open a terminal and run

ifconfig wlp1s0 up

And see if that enables wifi?